migration from home made CRM - quote issue -

Hi everyone:

We are moving from a local CRM, and I am exploring more choises. My first option was SuiteCRM and my first tests were great. No problem with Accounts, Contacts, Products, Categories. Even after a couple of days to develov several pdf templates, all OK. The pdf templates now are pretty nice.

Now, when I generate a quote, I load the part number for the product and loads the full description, If I remove some text in the Description field and save the quote.

why is not saved in the pdf templated? The quote in pdf shows the full product description, not the data in the quote form.

Please see the red marks in the image below.

Best regards


Hi, welcome to the forums and to SuiteCRM!

You probably have this problem:


which has already been fixed, but not yet merged and released. If you want you can apply the fix manually:



My problem is not what you tell me but thanks for your help. I really apreciate your quick answer because I see another posts with no answers from nobidy in the fĂłrum.

After think a lot about this issue, I found the solution and I wanna share with everybody. After a lot of search with google.

I tried with two VM by bitnami (versions 7.7.5 and 7.7.9) running in VMWare 12. Yesterday I tried with Google Cloud Platftorm running 7.8.3 (same situation). Today I upgraded to lastest versiĂłn 7.9.0 and the same behavior. I was really frustrated. Then, I decided to write to the FĂłrum.

Eureka happen to me and find it. How to confirm it? Building a new PDF template from scratch (zero).

I created a new PDF template.

I saw in the body of PDF template, the column with name “Description” with letters of color black and background with color light blue. There was a variable with name “$aos product description”

So, I deleted this valiable and I went to “Insert Field”, I selected “Line Ítems: Products” to find all the variables about the products and I found two “Description” and I tried the second

The first “Description” has the variable “$aos_products_quotes_item_description”

The second “Description” has the variable “$aos_products_description”

The solution was to replace “$aos_products_description” with “$aos_products_quotes_item_description”

and save it.

Now, I tested the PDF template with this change, and the same modified text in the quote is the same in the quote in PDF.

Thanks PGR and to the develoopers of this great open source solution.


P.D. I hope this help to all the people who is starting. I attached screenshoots to do it easier to understand.

1 Like


I have a another question related to this topic, for a extra long text, how can I separate the text between sheets automatically?

Best regards