max upload filesize error

I am doing a new install of suitecrm 7.10.9 with php7.2 on a digitalocean server. I am getting an error on the environment check saying I haven’t got 6M of max upload filesize.
My php.ini is set correctly with max upload = 6M and postmax = 8M. This is confirmed when I run phpinfo().
Why am I getting this error?

How are you running phpinfo?

  1. from the command line?
  2. From a separate PHP file you created on your server?
  3. From Admin / diagnostic, inside SuiteCRM?

For the newer versions you need much more than 6M, I would go for 20M.

Thanks pgr. I have run phpinfo from both a server file I created and from the suitecrm diagnostics. Both versions correctly show 6M upload max (I’ll increase filemax as advised soon).

Yesterday I had this problem myself and I realized both these php.ini values are relevant, increase both:

max_post_size
upload_max_filesize

I have increased both to 50M.
I have pushed past the error warnings and installed the system. It seems to be running ok, so maybe a problem with the validation ???
I also note that there a number of online comments re digitalocean servers not recognising upload_max_filesize, so maybe a provider issue.???

The phpinfo that you get from Admin / Diagnostic should be pretty accurate, it’s taken from inside the app, so if you can get the values effective there they were probably already allowed by your provider.

I would go for at least 64MB: Some of the packages have been bigger than 20MB.

I am getting a filesize error trying to upload the 8.0.0 beta.

The actual error is ERROR: uploaded file was too big: max filesize: 60000000

My php.ini file is as follows:
file_uploads = On
memory_limit = 128M
post_max_size = 90M
upload_max_filesize = 90M
memory_limit = 256M
max_input_time = 90
max_execution_time = 5000

And in SuiteCRM admin / system settings I have “Maximum upload size” set to 90000000

Is there somewhere else that I need to change a setting?

I have restarted apache and also rebooted the server a couple of times. I have a phpinfo() file as well and when I pull that up through a browser it confirms the php settings listed above.

Any idea?

Thanks a lot

I also verified that output from the diagnostic tool showed 90 instead of 60 and it does. I deleted the upload files from the cache but that did not work. I tried rebuilding the config file and a quick repair/rebuild but nothing seems to eliminate the error. I have no idea where that 60 is coming from. Any help would be greatly appreciate.

Thanks.

I think you’re trying to put the Suite8 Beta, which is a full install, not anupgrade, through the upgrade wizard, am I right?

You need to start a blank install, from scratch. Later on, an upgrader will be available, but not at the moment.

I was indeed. Thanks a lot. That error was driving me crazy. I still can’t get the beta to install but that is not related to this issue. Thanks again.

1 Like