MariaDB, RHEL7

Am new to SuiteCRM and would like to try it on an Amazon Web Services RHEL 7.1 image. Are there specific installation instructions for RHEL 7?

Also have the following questions:

  • Is MariaDB supported? … The http:////install.php wizard indicates that it can’t find the database but it is running on the local machine and it is possible to run the command-line mysql client against it.


if php is not picking up mariadb you likely haven’t install or enabled the php mysql exertion that is required e.g. php5-mysql

Thanks. That got me past the database error.

There are a number of not writeable file and directories. All the suitecrm directories are owned by apache:apache and they’ve been set using chmod -R 755 based on the installation instructions. The cache custom modules themes data upload config_override.php files and directories were set using chmod -R 775. Have also tried setting to 777 but the same error results.

The config_override.php file is 775 (have also tried 777). The contents of config_override.php is


Is there something different required on RHEL7?

Reference excerpt from suitecrm/install.php:

Component Status

The config override file exists but is not writeable. Please take the necessary steps to make the file writeable. Depending on your Operating system, this might require you to change the permissions by running chmod 766, or to right click on the filename to access the properties and uncheck the read only option.

Writeable Custom Directory

The Custom Directory exists but is not writeable. You may have to change permissions on it (chmod 766) or right click on it and uncheck the read only option, depending on your Operating System. Please take the needed steps to make the file writeable.

Writable Cache Sub-Directories

The files or directories listed below are not writeable or are missing and cannot be created. Depending on your Operating System, correcting this may require you to change permissions on the files or parent directory (chmod 755), or to right click on the parent directory and uncheck the ‘read only’ option and apply it to all subfolders.

Please fix the following files or directories before proceeding:

Writable Modules Sub-Directories and Files

Warning: Not Writable

Please fix the following module directories and the files under them before proceeding:
Writable Upload Directory

Warning: Not Writable