Maps page not found (URL not found)

I am running SuiteCRM version 7.11.10 on an ubuntu server version 18.04.3 (in virtualbox). Everything is working fine except maps. I have the API key set up properly and the geocoding test works fine. When I try to view a map I get a URL not found error. There are no recent entries in sugarcrm.log. The page itself pulls up, but the frame that should have the map does not.

Can you check your browser’s Developer Tools, Network tab, to get us the exact URL that is not found?

It looks like localhost/SuiteCRM is being inserted into the URL twice. I looked through config.php and php.ini but I didn’t see anything obvious.

Thanks a lot.

Thanks, this will be useful.

What do you have in your config.php for these settings:

  • site_url
  • host_name

Please check also config_override.php in case these values are also there. Thanks

site_url = ‘localhost/SuiteCRM’
host_name = ‘localhost’

There is nothing in config_override.php


I think that you should change 'site_url '. Suite decide that localhost is directory but not the site.

site_url = ‘http://localhost/SuiteCRM’

1 Like

Thank you. That kind of worked. After making the change you suggested, I still got an error. The new URL was:


since it wasn’t changing localhost to the actual IP address I changed it to site_url = ‘’ and that works.

So now how do I get it to work with a variable IP address?

Thanks a lot.

Which does address configure in your web server (nginx, apache and ect.)? You should use domain name there. This domain name should write into ‘site_url’.
And of course DNS should be worked.

Got it. I added the following into var/www/html/SuiteCRM/config_overrride.php

$config[‘base_url’] = BASE_URL;

restarted apache, and now it works.

Thanks a lot.