Manual upgrade from 7.9.4

I do not see an upgrade path from 7.9.4 to 7.11.1. My client has 7.9.4 and has moved to a new server since unable to correct issues.
I’ve upgraded PHP 7.0 to increase max_upload, max_execution etc to really high values. When I go through the admin->upgrade System check then to upgrade package it takes me to a blank page.
I see this in the error_log

18-Feb-2019 20:20:06 America/New_York] PHP Fatal error:  require_once(): Failed opening required 'upload://upgrades/module/TestPackage2019_02_14_103423-manifest.php' (include_path='/home/arcadiasales/public_html:/home/arcadiasales/public_html/include/HTMLPurifier/standalone:/home/arcadiasales/public_html/include/..:.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/arcadiasales/public_html/modules/UpgradeWizard/uw_utils.php on line 956

This is on line 956


Is there anyway to upgrade to current without having to use the Admin process since it is failing?


Here is your upgrade path

Please make sure that upload directory has right permission.


Thank you for the files. I’m a little lost. How do I apply these? In the Admin when I select Upgrade. -> Upgrade Wizard. System Check shows OK so I choose Next the Upload Upgrade Package step shows In Progress then goes to a blank page. I see in cache/upgrades/temp a file upgrade_progress.php which shows

Now each time I enter the Upgrade process the page is blank unless I remove this file. The same error is in my error_log file.

Can I just unpack the zip file(s) replacing the files within his folders?

You can delete upgrade_progress.php file and zip file from cache/upgrade and restart the upgrade process.


I removed the file upgrade_progress.php and the only file/folders in cache/upgrades is the temp folder which I’ve deleted. There is no cache/upgrade (singular) folder. I get the same results and the same error in the error_log. This is on the Upgrade System Check page. After that I still get the empty page. I am assuming I might have the option to upload the files but not.

File Permissions:	All Files Writable

Database Privileges:	All Privileges Available

Detected Settings:	All System Settings Requirements Satisfied

My server requires 755 for folders and 644 for files and the user and group are the users login. I’ve even tried setting the folders to 777 and that does not help.
Thanks for the help.

I do notice the error_log seems to be looking for this file “TestPackage2019_02_14_103423-manifest.php” I do not find this file when I do a find.
I found record of the date in the file custom/modulebuilder/builds/TestPackage/manifest.php
‘name’ => ‘TestPackage’,
‘published_date’ => ‘2019-02-14 15:36:25’,

Sorry to bump but looking for a solution.
Can I just use the upgrade files to overwrite the files starting with SuiteCRM-Upgrade-7.9.x-to-7.10.13 or must I use the Admin process which is not working?

OK so to help others. I had to remove everything in upload/upgrades folder then restart the admin. This time the process allowed me to upload the SuiteCRM-Upgrade-7.9.x-to-7.10.13 then continue with the upgrade process

1 Like