Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Lucene Index fails with a User name in search

I know the Lucene index is being deprecated. I’m on version 7.12.5 I think it’s still supposed to work. For the most part it does. However, when I enter a search that has a user’s first name or last name, the search crashes with blank screen. All other searches seem to work. For example. My name is “Paul” if I search for “paul” = crash (by crash I mean blank result with no warning of “not found”). If is search for “dave” (who is not a user) works great and finds all the “dave’s”. I’ve tried this with last names too. Same result. There are no errors in the log.

Anyone else? Or just me?

Have you tried rebuilding the index?

Thanks @pgr. I’ll give that a try and report back. It’s just weird it seems to work unless a users first or last name is put in.

Re-built the index. Rebuilt with out error. Search works just like before. Works great unless I enter a user’s first name or last name and then it fails (blank search results). Any query that results in no results shows “no results” as it should, any query that has results, shows them proper. (with the exception of user first/last names). Just wondering if anyone else has this issue or is it just me.

I don’t have an indexed instance where I can test.

If anyone has one, please try testing the scenario described above, it will only take a minute.