Logo not accepted after upgrade

I upgraded SuiteCRM from 7.10.9 to 7.11.12 successfully. However, I noticed that the logo wasn’t showing up. I tried loading a png and jpg logo and was told that it wasn’t the correct file format.

any pointers on how to resolve this would be appreciated.

Hi, welcome to the Community! :tada:

I would start by making sure your system is healthy in terms of file ownerships/permissions, since that is a common problem with new installations, and it would explain your issue (system can’t write the logo file, or can’t read it after writing it).

Do you see a bunch of labels in many screens showing as undefined?

If you go in Admin / Upgrade and start the wizard, how does the permission check go? (you can cancel the upgrade afterwards)

hi pgr
Thanks for the warm welcome.

I did have permission issues with the company logo at the start of the upgrade and that was resolved after changing the permissions. I changed them to be RWX (owner, group, others). Then the upgrade went fine.

I did a recheck as you suggested and all permissions are okay. However, now with the system upgraded I see that I have an issue on PHP version (7.0.32. recommend 7.1.0 or above).

I have noticed now that I have come back to SuiteCRM to log in that the logo appears. However, trying to choose a logo I am still getting the error.

I don’t see any “undefined” labels on my spot checks.

Thanks for the suggested areas to check.

Is this your own server, or shared hosting? Do you have SSH access?

In Admin / Schedulers, at the bottom, there are cron instructions. What do you see there? This will tell me the user name that your web server is running under.

Then we can check if your files and directories are owned by that user (permissions don’t mean anything without ownerships - both need to be correct)

Own server. Yes, I have access.

In order to run SuiteCRM Schedulers, edit your web server user’s crontab file with this command:
sudo crontab -e -u daemon
… and add the following line to the crontab file:
*** * * * * cd /opt/suitecrm-7.10.9-0/apps/suitecrm/htdocs; php -f cron.php > /dev/null 2>&1**

Ok, and if you run this command from the SuiteCRM root directory, what do you get?

ls -al

That’s the root directory of your entire server, I asked for the SuiteCRM root directory, for example, var/www/html or similar

Sorry… that’s still not it.

It need the directory where SuiteCRM was installed. You should find there a file called index.php, and suitecrm.log, and subdirectories vendor, modules, upload, etc.

Sorry pgr.

I spoke to a colleague and put me on the right track … I hope.

That’s it, thanks! I deleted your previous posts, no point in leaving that information out here.

Now - you’re not using the recommended ownerships/permissions scheme, you’re using something else quite different. It does seem to make some sense, though, there are only a couple of things that I fear might be insufficient. Did you make that permissions scheme yourself, or perhaps this colleague of yours’?

I will assume that your web server is running as user daemon who is also part of a group with the same name.

My concerns are that the cron jobs run from CLI and require execute bits on PHP files (these would have to be for Group if you keep the ownerships as root:daemon).

Hi pgr
I hope you are keeping well and safe.

Apologies on the long delay on replying. I’ve had a few distractions like many of us.

Thanks for removing those other posts.

I did speak to my colleague and he doesn’t remember changing any permissions.

Would resolving this be to apply the recommended ownerships/permissions? It there is a knowledge item to point me to would be appreciated.

This should do it (commands to be given from inside the SuiteCRM top directory):

  sudo chown -R daemon:daemon .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null