Local SuiteCRM 7.9.4/7.8.5 Install on Windows 7 64bit failing/suspending after DBCheck using XAMPP and WAMPServers, Bitnami SuiteCRM works though?

Hello all,

I have not been able to get the official downbloaded SuiteCRM install.php script to complete and install SuiteCRM on my local laptop. I have tried two different WAMP platforms (XAMPP and WAMPServer) and multiple version of MySQl/MariaDB as well as different versions of PHP.

It will not create the database tables etc and produces no other errors, the install script will not execute fully.

Install suspends after it successfully logs into the DB and does not proceed.

2017-08-16 10:54:51…installerHook: Could not find custom/install/install_hooks.php
2017-08-16 10:54:58…installerHook: Could not find custom/install/install_hooks.php
2017-08-16 10:55:01…Begin System Check Process *************
2017-08-16 10:55:01…XML Parsing Support Found
2017-08-16 10:55:01…MBString Support Found
2017-08-16 10:55:01…ZIP Support Found
2017-08-16 10:55:01…/custom directory and subdirectory check passed
2017-08-16 10:55:01…cache directory and subdirectory check passed
2017-08-16 10:55:07…/module directory and subdirectory check passed
2017-08-16 10:55:07…/upload directory check passed
2017-08-16 10:55:07…/zip check passed
2017-08-16 10:55:07…PCRE version check passed
2017-08-16 10:55:07…installerHook: Could not find custom/install/install_hooks.php
2017-08-16 10:55:07…php.ini location found. C:\wamp64\bin\apache\apache2.4.23\bin\php.ini
2017-08-16 10:55:07…Outputting HTML for System check
2017-08-16 10:55:07…No Errors were found *************
2017-08-16 10:55:08…installerHook: Could not find custom/install/install_hooks.php
2017-08-16 10:55:12…installerHook: Could not find custom/install/install_hooks.php
2017-08-16 10:55:55…Begin DB Check Process *************
2017-08-16 10:55:55…testing with mysql:mysqli
2017-08-16 10:55:55…Basic form info is valid, continuing Process.
2017-08-16 10:55:55…Testing user account…
2017-08-16 10:55:55…Connection made using host: localhost, usr: ********
2017-08-16 10:55:55…SUCCESS:: no errors detected!
2017-08-16 10:55:55…End DB Check Process *************
2017-08-16 10:55:56…installerHook: Could not find custom/install/install_hooks.php

I have necessary php optimisations:

Set max_execution_time=600
Set upload_max_filesize=10M
Uncomment (Remove “;”) php_imap.dll

I did manage to download and install the Bitnami 7.9.4-0 SuiteCRM build and it 100% works and I can use SuiteCRM (https://bitnami.com/stack/suitecrm/installer) however this is no good as I have to be able to install SuiteCRM multiple times as it is part of a development project and the Bitnami version is not the SuiteCRM version I need, I want the LTS build from SuiteCRM.com.

Bitnami SuiteCRM Stack ships with the following software versions:

  • SuiteCRM 7.9.4
  • Apache 2.4.27
  • MySQL 5.6.37
  • PHP 5.6.31
  • phpMyAdmin 4.7.2

The WAMPServer build uses:

  • Apache 2.4.23
    – MySQL 5.7.14
    – PHP 5.6.25/7.0.10
    – PhpMyAdmin 4.6.4

And I try to run SuiteCRM 7.8.5

I have used HeidiSQL to test I can connect to the database locally and I can, I have also tried this with Firefox and Chrome, both get stuck and do not proceed.

Does anyone know why th install pauses indefinitely with no errors?


OK so I think I need to go back to school…

I was not supplying the correct details on the config page, I had ticked “Same as admin user” when that user did not exist at all…

Problem resolved. :blush: