Lead search is broken for imports

When I try to search my lead list by the Created By heading in advanced search, I get no results unless the lead is something that I’ve created in SuiteCRM, as opposed to importing from our old CRM (Dynamics if it’s relevant). I don’t know how to fix this, because the Created By person is listed correctly in the lead list otherwise.

Does it allow you to search by other fields like name or assigned user etc?
are all the created by users still active users within the CRM(With the same username ID that was in the .csv)?
Guessing youve tried a quick repair and rebuild after the import?

Most of the contact information works for search. The issues appear when you’re searching by a user in the system (as creator, modifier, etc).

The names should all be the same from the import.

I hadn’t tried a rebuild because I also noticed an odd thing where my name doesn’t show up as my name in the Created By field if I make the contact in Suite. Instead, I’m just listed as “1.”

1 is the User ID so usually the admin. Could you attach some screen shots? :slight_smile: