Lead Import Wizard Not Importing Custom Fields

I am using the import wizard for leads and everything works great but my custom fields are not getting into the database. I even tried it using the exact file from the Import File Template. It still didn’t bring in the custom fields even though they are listed in the template.

Any one have any ideas?

The import wizard even rejected rows where a custom field within the row did not match a value in the drop down field list. After adding these items to the drop down list, the rows were imported and yet the very fields it was complaining about when it rejected, did not get populated.

Does anyone have any ideas of know of a log file I can check out to further troubleshoot this? I would really like to import these records in full.

Another interesting development.

The import worked fine within my staging environment and then in production. Staging and production are both running on linux with a mySQL backend. My development box is Windows 10 with mySQL.