LDAP Authentication stopped working after upgrade 7.8.8 => 7.8.9

Good Morning,
after upgrading through the wizard from 7.8.8 to 7.8.9 users are no longer able to login.
suitecrm.log has some entries like:

Wed Dec 20 08:15:23 2017 [14671][-none-][FATAL] FAILED LOGIN:attempts[1] - myusername
Wed Dec 20 08:51:12 2017 [14653][-none-][FATAL] [LDAP ERROR][34]Invalid DN syntax

Could you please give me some advice how to fix that?

Best regards

P.S: if the “password forgotten” option is set, i receive the mail for password reset and can log in. After logging out i can not login again…


that’s likely a bug, but one that’s proving hard to fix since the developers can’t reproduce it… it happens to some people, in some particular circumstances only…

Thanks for that hint

on one of the machines i cant even get a reset email as it was not configured due to LDAP connection. Do you have any idea how to enable the “Password forgotten” Mail without possibility to enter SuiteCRM? I can’t even get in as admin because all users are rejected

Thabks for your help

Sorry, this is all new code and I don’t know how it works.

I do know how to reset a password directly in the database, would that help?

thanks for your help. I don’t think it will help. Even after reset the password by reset-mail the next login will fail.

What works on one machine: send a reset-password mail, change password and login. If you stax logged in everything is fine. If you log out the procedure starts argain…

On my second machine it is worse. I did not enable sending a password-reset mail, so ican neither login nor send a mail for “forgotten password”. If i could find the settings for this feature i could press the “forgotten password” button and were able to log-in by the above mentioned method.

Do you know which settings in Database or config.php are necessary for sending the password-mail?
Regards Georg

I see this in my config.php on Beta3:

  'passwordsetting' =>
  array (
    'SystemGeneratedPasswordON' => true,
    'generatepasswordtmpl' => 'bcd0354f-bfdd-2b52-80de-58c6b7d97391',
    'lostpasswordtmpl' => 'c0639b3b-a124-8f6a-c697-58c6b7927700',
    'forgotpasswordON' => true,
    'linkexpiration' => true,
    'linkexpirationtime' => 24,
    'linkexpirationtype' => 60,
    'systexpiration' => 1,
    'systexpirationtime' => 7,
    'systexpirationtype' => '0',
    'systexpirationlogin' => '',
    'minpwdlength' => 6,
    'oneupper' => false,
    'onelower' => false,
    'onenumber' => false,
    'factoremailtmpl' => '',

Check also config_override.php.

1 Like

thats what i have in antother instance too. But its not sufficient to send the mails, found mail_template table in DB and am searching for the rest

Ok. Try checking if your user has an email configured - otherwise it can’t send to the address.

There’s another trick I know that could be useful: in the “users” table, there is a field with all the user settings put together in one big field that looks like it’s encrypted. It’s really just base64 encoded, so you can put it into this site for example:


and you can see the array of user options. Try looking inside that.

It’s strange, but it was … the default theme!! We use SuitePimproved-Thme which did not allow login after upgrading 7.8.8 to 7.8.9

After resetting the default theme to suiteP everything war working fine again

Thanks for your help again