Layout View - Recycle bin

The recycle bin disappeared and the delete button is grayed out
Nothing happens when trying to remove a field
This means customizing a view is impossible

Version no 7.6.3

All the settings are in accordance with suitecrm requirements


It seems there is no response of solution

You’re right, I also have the Recycle Bin missing from displaying but the drag and drop do work.

best regards

Are you sure this is a problem? I didn’t know about this Recycle bin and usually, to remove a field from the view, I just drag it from the right onto ANY button on the left, and they are swapped.

I don’t see the logic of deleting fields in views, only the logic of removing them from view. Maybe that’s why the “delete” area is grayed out. Maybe it’s there just to delete “fillers” or some other reason.


The recycle bin is used to remove the panels filled with fields, if you drag a panel to the left side of the studio the panel wont stay there, you need to drop it on top of the recycle bin (used to be, it is on Suite7 theme) or just simple on top of the word delete.

You’re right that if you drag one filed to the left panel of studio it will stay there as removed from the view, but the delete feature if for panels in views that contain the fields.

best regards


Oh, I never tried to delete an entire panel, maybe that’s why I never understood this. Thanks for the lesson.

Maybe he should just go under the hood and remove the panel from the files, instead of from Studio. This looks like a bug, but it’s no point getting stuck just because of this…


Do you know how to change layouts manually, through the files? If you need help please tell us exactly which modules and which views you need to customize.


Here are a few things for you to try:

  1. Workaround: just drag any field from the right OVER any field on the left; this will swap the fields. That might leave you a few unwanted fields anyway, but you can just use fillers for all of them and drag them all to the bottom.

  2. Test: Change the theme from SuiteR to Suite7 and check if it works. There was an issue on Github related to this a while back (although it’s closed and things should be working). Let us know if it worked.

  3. Solution: Remove the fileds directly from the files. For the Leads module, EditView, go to

if that file doesn’t exist, create it by copying the same file but without the “custom”, like this (if it’s Linux; execute from the root of your SuiteCRM installation):
cp modules/Leads/metadata/editviewdefs.php custom/modules/Leads/metadata/editviewdefs.php

Please keep the discussion here, not on the other thread, and make sure you read and follow all our instructions (sometimes you don’t answer our questions! it’s hard to help you that way).