Language packs do not install

I try with no seccess to install French Canada or French language pack on my Suite CRM. I saw in the forum that these package sometimes create trouble because of apostrophe that is somtimes note entered correctly in php. So I tried two other laguages (Italian and Spanish (Mexico)). No more success. The packages load in the upload section (see image Module_Loader_SuiteCRM.png attached). However, when I try to click install with any module, the commit button never appear. Only a message with the location of the language pack in my web server appears (see attached picture Install_bug_with_no_commit.png). If I look on my web server, all packages are there in the folder /suitecrm/upload/upgrades/langpack (see attached picture Language_packs_on_web_server.png). Could it be a permission that I do not have on my web server? My SuiteCRM version is 7.10.11 and I installed it on web server through CPANEL and Softaculous.

Are you using the latest package? I just tried downloading French - Canada and it says version “” in the manifest.

You seem to be trying with, that’s seven versions of SuiteCRM earlier…

Thank you pgr. However I just tried to install language pack ca-fr and it still does the same. No commit button appear. Any other idea?

You can clear upload/upgrades/langpack/ on your server.

And check your php.ini for these variables, maybe increase a bit:

memory_limit (at least 256MB, better 512MB)