Language pack installation error: Could not copy file cache/Upgrades/temp

I have suitecrm 7.3.0 installed in linux. I download language pack (pt_BR_SuiteCRM_v7301.zip) for suitecrm 7.3 from here http://sourceforge.net/projects/suitecrmtranslations/files/SuiteCRM%207.3/. Then i going to Admin / Module Uploader and try of install this language and i get this error: Could not copy file cache/upgrades/temp/nE09JM/./manifest.php to /var/www/html/crm73/./manifest.php. To how i have one test server i give all rigths to folders and files as 777.

How i can to fix this error and install fine my language pack?

Regards,

Edgar M

Hi,

Is this error a FATAL error, or something else like A warning/notice?
Does it show on the screen or in your suitecrm.log file?

Make sure that your PHP has the zip extension enabled.
It may also be worth your while to set the User and group of all files/folders to the correct value.

You can do this with the command sudo chmod -R : .
Just remember to replace and with the appropriate values for your instance.

Thank you John.

Yes is one FATAL error. I can’t to follow and i logout and i cant to see the language installed in login page.

Yes, this is showed in screen page. However i search the suitecrm.log file in the root directory and i can’t find it. Why i cant to find it?

Yes, i have my zip extension enabled in my PHP.

Then is possible to be one issue of rigths of user and group of the files and folders. By now all the files and folders have the user and group root, and 777 to all. I need to set othe user and group different to root? which user and group i need to assign? i have one centos 6.5

Hi,

User and group for centOS is ‘apache’ I believe.

Also,
If you open your index.php file and add the line:

ini_set('display_errors',0);

in the location shown in the attached image.
As errors should not be displayed on your instance. However, if you want errors turned back on at a later date, simply remove the line.

John, i set apache user and group to all my folder files, and did sudo chmod -R 755 *.
I add ini_set(‘display_errors’,0); to my index.php file as show your image. and i have the same error. Show the attached files please:

How i can to see logs? or what to does this ini_set(‘display_errors’,0); ? Which other thing i can to do?

For the record, we usually recommend the permissions:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

However,
Your CRM was displaying warnings/Notices, the line ini_set(‘display_errors’,0); stops this, as it can cause issues across the entire CRM when enabled.
The reason there was no error in your suitecrm.log file is because that is set to log errors that it deems FATAL, not notices and warnings like what you were seeing.

Now that you have set it to 0, are you able to upload and install the language pack?

John, i did sudo chmod -R 755 * and sudo chmod -R 775 cache custom modules themes data upload config_override.php. I get the same error.

i disable logs adding this line ini_set(‘display_errors’,0); to my index.php

I can to upload the package language as show this attachment file:

Is have some strong in this installation in linux, because i have other installation as bitnami in windows, too as suitecrm 7.3 and here if install fine this language pack. What other thing i can to fix?

Hi,

Are you now able to click Install and proceed with installing the package successfully, and are you able to use it?
You will have to log out and choose the language from the log-in screen. See attached.

Also,

Sorry, Could you clarify what you mean here? I’m afraid I don’t understand.

No John, when i click over Install button, after i click over Commit button, i get the same error in the screen:Could not copy file cache/upgrades/temp/RmqDLF/./manifest.php to /var/www/html/crm73/./manifest.php

Too i did logout but i can’t to see Portuguese language, i can only to see english and spanish language.

The other is that i have one installation of sugarcrm 7.3 in windows 8.1 and here if i can to install this portuguese language pack.

Can you give one email or skype please?

Hi,

I was able to find a local instance that had this issue, so i could look into it greater.

The following steps resolved the issue for me:

  1. Go into your config.php file for SuiteCRM and find the array:
    ‘default_permissions’ =>
    array (
    ‘dir_mode’ => ,
    ‘file_mode’ => ,
    ‘user’ => ‘’,
    ‘group’ => ‘’,
    ),[

Make these values equal this:
‘default_permissions’ =>
array (
‘dir_mode’ => 1517,
‘file_mode’ => 420,
‘user’ => ‘apache’,
‘group’ => ‘apache’,
),

2. Navigate to your instance’s directory and delete the cache folder. If you want, feel free to make a backup of it, but it will be rebuilt anyway.
Then, Navigate to the Admin > Repair menu, run a “Quick Repair and Rebuild”

  1. Set permissions again to:
    sudo chown -R apache:apache .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload config_override.php

  2. Find the Language Pack’s .zip file and set the permissions on it to 777

  3. Go to Admin > Module Loader.
    Click “Delete Package” next to the Language Pack.
    Browse to the .zip file, and re-upload it after settings its permissions.
    Click “Install”

It may take a while to install, as it has to rebuild a few directories, but it should Hopefully succeed. If not, please ensure that you have followed these steps precisely.
If you have any issues with any of these steps, feel free to ask.

1 Like