JJWGoogleMaps module

I have the module settings working and the Geocode test works. I have created a map but when i click on the map the window opens to show the map but it reports a DNS error, It appears to be looking for an index.php file but I can’t even find one. It is using the address http://crm.illuma.co.uk/crm/index.php?.

http://crm.illuma.co.uk takes you directly to my SuiteCRM webserver and opens the default website which is my SuiteCRM web site. This web site is in a folder that has the full path of /var/www/crm (I’m using Debian and Apache). i can’t find a file index.php anywhere?

Is your CRM in the main directory or in the crm sub directory? It seems JJW wants to link to the crm sub directory.

My SuiteCRM website is all in a folder called CRM which resides at /var/www/. So it is not in the root folder for websites, it is in a sub-folder called crm below the root folder for websites. I know by default the folder that holds the SuiteCRM folder is called SuiteCRM and the one that holds a SugarCRM website is called SugarCRM but it seemed more logical to call it simply crm. My DNS name crm.illuma.co.uk takes you straight to the webserver and kicks off the default website in apache which I have set to be “CRM”.

I have the module settings working and the Geocode test works. When I go to Geocode Addresses, I have zero objects geocoded. All fields are zero accept the total. If I select reset and then the module, nothing happens. Everything is still zero. My install is:Version 7.1.2, Sugar Version 6.5.17 (Build 1220)

@gbirk
@rowlandkeable

Have you set up the cron job correctly?

The cron job has to run every night, to geocode all your addresses that haven’t yet been encoded.

From the page Admin / “Geocoded Counts”:

In my cPanel I setup a Cron Job using the suggested command line provided in Scheduler after … Note: In order to run Sugar Schedulers, add the following line to the crontab file:

In Scheduler I setup a job “Maps” to run mydomain/SuiteCRM/index.php?module=jjwg_Maps&entryPoint=jjwg_Maps&cron=1

I have the following errors in my Log:

Fri Jul 18 19:20:28 2014 [9076][1][FATAL] Query Failed: SELECT count(*) c FROM accounts LEFT JOIN accounts_cstm ON accounts.id = accounts_cstm.id_c WHERE accounts.deleted = 0 AND accounts_cstm.jjwg_maps_geocode_status_c = ‘ZERO_RESULTS’: MySQL error 1054: Unknown column ‘accounts_cstm.jjwg_maps_geocode_status_c’ in ‘where clause’

Fri Jul 18 19:20:28 2014 [9076][1][FATAL] Query Failed: SELECT count(*) c FROM leads LEFT JOIN leads_cstm ON leads.id = leads_cstm.id_c WHERE leads.deleted = 0 AND leads_cstm.jjwg_maps_geocode_status_c = ‘INVALID_REQUEST’: MySQL error 1054: Unknown column ‘leads_cstm.jjwg_maps_geocode_status_c’ in ‘where clause’

My installation is a SugarCE Migration to SuiteCRM. Under Contacts > Layouts > Sugar Dashlet > Sugar Dashlet ListView, I compared my fields to a friend’s installation that started with the suite CRM Core files.
I am missing Longitude (jjwg_maps_lng_c), Latitude (jjwg_maps_lat_c), GeoCode Status (jjwg_maps_gecode_status_c), and Address (jjwg_maps_address_c).
How do I go about repairing my install?

anyone have any suggestions…

It looks like your database is missing columns that JJWG_Maps was supposed to have installed.

Possibly it’s out of whack because the upgrade from Sugar to Suite maybe wasn’t designed to take into account JJWG_Maps already installed…?

Have you tried Admin / Quick repair and rebuild ? What this does is resync the database schema with the cache variable definitions…

Look carefully at the output of the Quick repair rebuild. If Suite detects a major difference, and it should, then it’ll suggest a command to run to fix it

1 Like

Thank you - I just tried that and there was no command to run to fix.

Audit table for jjwg_Mapss already exists. skipping…
Audit table for jjwg_Markerss already exists. skipping…
Audit table for jjwg_Areass already exists. skipping…
Audit table for jjwg_Address_Caches already exists. skipping…

Also, my original Sugar never had JWG_Maps already installed.

I am wondering if I should just download JWG_Maps and do an install?

  1. First I suggest backup your crm files and database. Just to be on the safe side.

  2. Then, you can choose what to do next.

A. I’d recommend sharing this thread with the dev, Jeff Walters.
Reason being, this could very well be a bug, and he’d really like to know about it, so he could fix it !
http://www.jjwdesign.com/
jjwdesign@gmail.com
On his site he says,
“Note that the Issues section (on github) may be used to send in your issues and/or enhancement requests.”
https://github.com/jjwdesign/JJWDesign-Google-Maps

If it is a bug, (maybe his code is failing to cope with a relatively common scenario, the upgrade from Sugar 6.5 to Suite 7)… then he would probably fix it quickly, and your Maps module on your CRM system will be working again.

B. You could try installing the upgrade package over your existing JJWG_Maps that came with SuiteCRM - it would work only if the version of JJWG_Maps that shipped with SuiteCRM was 2.0 or higher.
http://www.sugarforge.org/projects/jjwgooglemaps/
http://www.sugarforge.org/frs/download.php/11179/Google_Maps_v2.1.19_Upgrade_for_v2.zip

C. You could try installing the full package 2.1.19, over the existing JJWG_Maps that came with Suite
http://www.sugarforge.org/frs/download.php/11178/Google_Maps_v2.1.19_for_v6.zip

B and C are risky in the sense that they could solve the problem, but there’s a chance they could complicate it further.

I’d definitely go with A, but it’s your CRM, so it’s up to you if you want to chance it and try B or C.

1 Like

Last night I went with "C, installing the full package 2.1.19, over the existing JJWG_Maps that came with Suite. It worked and our Team in the field is already using the Maps feature in QuickCRM. Thanks for your help.

Awesome!
Very glad you’re up and running on JJWG_Maps 2.1.19 !
Kindly consider a paypal donation to Jeff Walters he would really appreciate any amount in the range $5 to even $500.