JJW Design Map not working on 7.6.3 after upgrade


i upgraded a 7.1.8 istance to a 7.6.3 following this flow:
7.1.8 => 7.2.3
7.2.3 => 7.3.2
7.3.2 => 7.4.3
7.4.3 => 7.5.3
7.5.3 => 7.6.3

When i geocode records, i experience no problem.
When i try to map them i see a blue sea…:

What can i do to solve it?

i tried with Chrome and Firefox, on a local LAMP environment and on an hosted LAMP one,
with Suite7 theme and also with SuiteR one

i found myself the solution:
copy the view.map_markers.php from a clean 7.6.3 istance to the custom folder and change the Cluster Google icons.
This means:


and change
MarkerClusterer.IMAGE_PATH = “//google-maps-utility-library-v3.googlecode.com/svn/trunk/markerclustererplus/images/m”;

MarkerClusterer.IMAGE_PATH = “//cdn.rawgit.com/googlemaps/js-marker-clusterer/gh-pages/images/m”;

1 Like


I can’t even get to that screen to see if it’s working for me normally and I have made all of the changes you listed, I just keep getting an error about API key, even thought I tried entering URL with API KEY that I registered with free google account:

Geocoding API URL:
Original: https://maps.googleapis.com/maps/api/geocode/json?sensor=false
Modified: https://maps.googleapis.com/maps/api/geocode/json?key=the_free_apikey_from_google_account

Does anyone knows what’s wrong with this setup, I have contacted developer, but he is not responding,and then I found that project is no longer supported while searching the Suite/Sugar forums.

Best Regards,



Try this.

Copy these files:


To this directory (accordingly):


And in each file search for “sensor=false” keyword. After this keyword add string “&key=YOUR_API_KEY”.

URL after modification should look similar: “”

You can get your YOUR_API_KEY here: https://developers.google.com/maps/documentation/javascript/

Good luck


Thank you for you reply. I tried and make changes you mentioned but now I got an error of “Request Denied”, it seems like Google is not recognizing API key.

I opened up both browser and server key and none of them works, they are activated. Ip address of SuiteCRM server is in allowed list with domain name too.

In all of the files my URL looks like you already explained plus “&libraries=drawing” This is at the end. but it does not change anything if I remove it or not, it’s still the same error.

Several suggestions:

  1. GMaps works with “Create Markers” action?
  2. Do you left “sensor=false” param?
  3. Try to add https or http to src link (https://maps.google.com/maps/api/js… or http://maps.google.com/maps/api/js…)
  4. Google Maps JavaScript API key problem, check it:
  • You have not activated the Google Maps JavaScript API Web Service in the Google API Console.
  • [strike]The key parameter is missing from your request.[/strike]
  • The key parameter does not match the your API key in the Google API Console.
  • Your API key has not been correctly set up in the Google API Console:
  • If you are using a browser key, check that your allowed referer(s) are correct.
  • If you are using a server key, check that your allowed IP(s) are correct.
  • Android and iOS keys are not supported, please use a Browser or Server key.
1 Like

Hi RemovE

Thanks for the reply.

Just checked the folders and this is all I have


There are 2 other files in there but they don’t match what you have below.

So I am missing some. Maybe they didn’t come with the 7.6 SuiteCRM install.

Have not idea how to reinstall this module

Actually, did find the files - need to put my glasses on.

Only thing is I couldn’t work out why I couldn’t copy files to the /modules/jjwg_Areas/views/ and /modules/jjwg_Maps/views/.

There was no views folder there so I created it - but it wouldn’t let me create it as there was another views file there - text or php.

I renamed both the view files to view1 and then created the view folders in each and copied the files across.

Changed the sensor to add the API part to it.

Still didn’t work - but then worked out I actually have to type in my API key - this should be done via the Admin site rather than hard coding - going to be hard for non-tech types to do this.

So now have the maps working (or showing)

Only thing is how to work out how to get the leads to show on the maps. Unsure how a Cron should look as did set one up but it doesn’t work.


I am guessing the Cron is there it update leads to get latitude and longitude - not sure how to do it. I have 97 leads. About 36 are showing in the Map Address Cache section of the ALL menu and they have longitude and latitude coordinates - not sure how they have them

Anyway, so close.

I will search the forums some more but if anyone here knows how to create a Leads map and knows the correct Cron then great.


Thank you RemovE. Adding https:// in front does the trick, option 3) Try to add https or http to src link (maps.google.com/maps/api/js… or maps.google.com/maps/api/js…) now map is displayed but it still does not show any for instance Contacts on quick Radius Map or with Add new map. There is just one marker present with default location and I think that it’s somewhere around Texas, US and it does not change no matter what you type in.

Maybe it has something to do with Geocoding Addresses in admin panel not being setup correctly, I have double checked and I have filled in address fields for around 7000 Contacts, primary address is setup as main in Google Maps settings page for Contacts.

I also have this problem. I’ve made all the changes suggested as well, as some other ones where there are code changes on Github. I can get the map to display and all my addresses are geocoded. However, when I do a radius map, it only shows the address that I input and no other addresses???

How can I get accounts and leads to show on the map?