IP for SUITECRM is different after Virtual Machine reboot.

Hi all,

I had a look in the forum, but couln’t find an answer.

I installed the VM using DHCP and imported some users and language packs.

I then tried importing 20000 accounts. took a while and finally stalled out at 9000. So I reset the virtual machine.

When I restarted the IP was different b[/b]. going to “” brought up the option to open suiteCRM (at and UCS administration at The admin panel works as expected but the link to suiteCRM does not.

If I goto the page loads, BUT I can’t log in as it can’t find the LDAP server, that I gues it thinks is at

Any ideas?



I don’t think these are SuiteCRM questions, these are sysadmin questions of the system you’re using. I don’t know anything about Uninvention to help you specifically.

DHCP provides dynamic IP addresses, so no wonder they change. You might need to get a static IP for your server, which you can probably achieve by making a DHCP reservation for it on your DHCP server, or by going without DHCP and just assigning yourself a static IP.


Thank you for the quick reply. I asked here as the VM is from the SUITECRM website. I have no clue how to change the linux VM from DHCP to static IP, whats more as I understand it both the IPs should have been the same after a reboot.

Where can I ask for help on this topic?

It’s a recent addition to our website, and I never installed it myself. Maybe you can try on any Uninvention support sites, or find out what the underlying OS is and search for help on that OS… I’m sorry I can’t help further, I really don’t know :frowning:

Hi D.deBruine,

There does appear to be something maintaining the IP address within SuiteCRM as I’m having a similar issue to you. If you’re using the same VM I am, it appears to be an Ubuntu VM. I also had it set to DHCP and when it got a new IP address, the pages couldn’t be accessed. When I access on the new IP address, the admin page will load, but the VM pauses when I enter the networking section in the admin page to make an IP updates.

I’ve then tried going the other way and setting a static IP for the server that matches the old one, and set the DHCP server to assign said IP to the VM, but it doesn’t appear to solve the issue. Additionally, if you open the VM with a normal start (not headless mode) you can see that the page before the terminal prompt will list the old IP.

I’m still looking around at how to solve the issue, so if I figure it out, I’ll re-post on here.