Internal Server Error For several pages

Hi ive managed to Install the CRM on my server most of the pages display and work ok apart from several page link the home page, import pages and a few other when you go to view them it comes up with:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Why hello @LukeGBM :wave: Welcome to the SuiteCRM community.

Okay, first off, you will need to look at your PHP error log on your server. This should narrow down what is flagging this up. It could be as simple as file permissions or something else.
Depending on you set up you may need to find those error logs via a cpanel or by command.

Hi Cullub. I have suggested everything they have said and updated everything but still doesnt work. They sent me the below and at the end they have aske done to may then go back to you and ask about debugging. Hello Luke,

Thanks again for contacting technical support at DreamHost!

I understand you’re experiencing issues with your suite CRM set up on” via the following path
SuiteCRM”. Upon further
review, we can confirm ISE related errors occurring when testing the home
page(as mentioned) and intermittently occurs for other pages such as
quotes, calendar. However, reloading or clicking another page and
returning back to the same page such as “contacts” allows it to load

When reviewing the error logs via the path listed below, we still
continue to show the following error when testing the pages which
indicates an issue with the .htaccess coding/configuration.


Error generating:
[Fri Oct 08 12:05:43.404815 2021] [core:alert] [pid :tid
140193005364992] [client]
RewriteBase: argument is not a valid URL, referer:

To help in logging all generated errors relating to php, we’ve gone ahead
and set up php error log which can be done using the following link. When
testing how the pages, we still were unable to generate any errors in the
php.log which should reflect via the following path
“/home/dh/php.log” if/when a php error occurs.

Error logging path/file:

We also tested enabling Wordpress debugging as well to verify if any
related errors reflect when testing the service. The only error
continuing to generate was the following listed below. As such, it may
be worth troubleshooting plugins and theme to help rule out any potential
issues causing conflicts when making the request to the home page

It may also be worth looking in any out of date plugins and themes to
ensure they do not pose a conflict with the CRM suite as well. As we’re
noticing the current theme and 4 plugins showing an update available.

dh_:~/$ wp theme status
3 installed themes:
UA Extra 4.9.4
UI twentytwenty 1.7
UI twentytwentyone 1.3

Legend: A = Active, I = Inactive, U = Update Available

If still continuing to experience issues, it may be worth reaching back
out to the CRM developer to see if they have any options of debug/logging
specifically for the CRM service to see if that helps in isolating the
issue further.

Should you continue to have issues or additional questions we can help
clear up, don’t hesitate to contact us back anytime!

Best regards,
Greg V
DreamHost Technical Support

Hey Luke!

Thanks for responding. First off, you using SuiteCRM 8 RC? This hasn’t hit production release so there may be some areas that have issues so I would advise not to use it for that purpose just yet.
However, if you are trying this version out for testing purposes then lets see what the issue is and hopefully it will help others once production of Suite 8 is released

Is this instance of SuiteCRM installed within a wordpress folder? i.e. is waterside-group a wordpress instance and then WatersideCRM is where the SuiteCRM is situated?

Yes thats correct waterside-group is a wordpress site install and WatersideCRM is the CRM install with its own SQLDatabase

I wonder if this might help you debug:

Hi @LukeGBM :v:t5:
and welcome to the SuiteCRM community :partying_face:

Edit {document_root}/public/legacy/.htaccess at line ~22 :

RewriteBase your_domain/legacy

and remove your_domain so it’ll be :

RewriteBase /legacy

It should do the work for now but I am not sure it’s 100% correct to do it that way.

1 Like

Hi @maxonss, @LukeGBM ,

@maxonss, the following is correct

Hi both yeh that sort of seemed to work, well the error screen didn’t appeared but seemed to loose styling for some reason.

Is it easy to downgraded the version just so I can see if that is now the issue? Is so is it easy to do so.

Hi @LukeGBM,

I’ve noticed that you are on a subfolder.

Could you try changing your RewriteBase to something like

   RewriteBase /WatersideCRM/public/legacy

By the way, for security reasons, we usually recommend pointing the vhost to the public folder in SuiteCRM.

From what I’ve understood you also have a wordpress. So maybe you could use a subdomain like crm.<your-domain>.com, and then point the subdomain directly to public.

  • note: if you do so, you need to change the RewriteBase back to /legacy