👋🏾 Looking to join our SuiteCRM Community Working Group? 💌 Open invitation throughout January. Check out all the details here 👈

Installing SuiteCRM 8 Development mode


I’m trying to install Suite8 using the developer guide (for dev environment) and I’m getting this error while launching the command : yarn run build-dev:shell

Developer Install Guide :: SuiteCRM Documentation

Hi @Edun,

Thank you for trying out SuiteCRM 8 and for the feedback.

@samus-aran has moved your post to a separate topic as it will most likely require some back and forth.

From the error pointed above it seems that the shell build is not being able to find the core and common package builds.

did you run the following before running yarn run build-dev:shell

  1. yarn run build-dev:common
  2. yarn run build-dev:core

Please not that the build commands need to be built one after the other in the following order:

  1. yarn run build-dev:common
  2. yarn run build-dev:core
  3. yarn run build-dev:shell
1 Like

Hello Clemente,

Yes, I have run the commands in the order mentioned.

While investigating further, I saw that the core build was not being built as should (the core build crashes), thus that is why build-dev:shell can’t find a ‘proper’ dist/core .

Therefore, the problem is building the core part.: yarn run build-dev:core

Here is the output when you run build-dev:core :





As you can see from the screenshot, it is being exited during the “BUNDLING TO UMD” that it fails and just exit the process. It is working fine for the build-dev:common , thus removing the idea that it might be an environment issue. One more thing to note, the yellow lines are warnings and I don’t think they are the cause of the problem.

I’m on a docker, with PHP8 (mode production is working just fine, i’m trying to set up a development environment).

On top of that if I try to run ng build core --version --progress , it tells me that the option ‘version and progress’ cannot be found, which is very problematic if you want to debug the command.

Any idea or solutions?

Regards,

Hi @Edun,

Thank you for the detailed information.

What versions of the following are you using?

  • node
  • yarn
  • ng cli

Node:
node -v
v16.13.1

Yarn:
yarn -v
3.1.1

ng cli:
@angular/cli 12.1.0

Hi @Edun,

Thank you. I think the problem might be with the node version.

Could you change your node version to 14.x, please? Angular 12.x does not support node 16.x.

Hi @clemente.raposo ,

Thanks for your reply.

I have changed my node version to 14.18.2 and I still have the same problem.


I tried to dig deeper on this problem, and found this : ngcc: processing of recently published UMD bundles may fail · Issue #44037 · angular/angular · GitHub

It is possible that some libs are not compatible with the UMD and they suggest disabling UMD as we use es2015. Do you think it is the problem? If yes, we need to find a way to add the properties option to the NGCC compiler.


Can you send me the versions of node, yarn, ng cli, ng-packagr that are working in your environment please?

Regards,

Hi @Edun,

Yes, here go my versions, I’ve run ng --version


     _                      _                 ____ _     ___
    / \   _ __   __ _ _   _| | __ _ _ __     / ___| |   |_ _|
   / △ \ | '_ \ / _` | | | | |/ _` | '__|   | |   | |    | |
  / ___ \| | | | (_| | |_| | | (_| | |      | |___| |___ | |
 /_/   \_\_| |_|\__, |\__,_|_|\__,_|_|       \____|_____|___|
                |___/
    

Angular CLI: 12.1.0
Node: 14.18.2
Package Manager: yarn 1.22.10
OS: linux x64

Angular: 12.1.0
... animations, cli, common, compiler, compiler-cli, core, forms
... language-service, localize, platform-browser
... platform-browser-dynamic, router

Package                         Version
---------------------------------------------------------
@angular-devkit/architect       0.1202.14
@angular-devkit/build-angular   12.2.14
@angular-devkit/core            12.1.0
@angular-devkit/schematics      12.1.0
@angular/cdk                    11.2.13
@schematics/angular             12.1.0
ng-packagr                      12.2.6
rxjs                            6.6.7
typescript                      4.3.5
webpack                         5.65.0

Hello @clemente.raposo ,

Thanks for your reply.
I did change my node version to 14.* and run npm update / install, and it worked.
We should update the dev installation guide and put the appropriate versions.

But now, i’ve reached the last step which is
yarn run build-dev:shell

And I’m getting a timeout (different errors) after around 15minutes.


I keep getting different errors while trying to run it again.

How much time does it take to run the command?

Hi @Edun

On my local running yarn run build-dev:shell takes 94.04s.. When developing what I usually do is to have build-dev:core and build-dev:shell with --watch. So on each change it will only rebuild the part that was changed. That makes it a lot faster.

The problem with your instance could be the RAM limit ng build command require a lot of memory, really a lot. The following is a screenshot from the System monitor on my local. It does not use all this memory during the whole process, just at the peak.

Yup,
the problem is the process is being killed either due to time-out or max memory limit as i’m in a docker environment.

Therefore, i used build-dev:shell --watch and it worked.

Until I have a more stable solution, i’ll continue using build-dev:shell --watch.

Thanks for your help.

Hi @Edun,

Great! Glad you were able to solve it

1 Like