installing on ubuntu 16.04.1

guys,

am trying to install suitecrm on a ubuntu, without a gui. Anyone who can point me to a tutorial? Seems i also need to install apache and php, looked for a decent up to mdate, tutorial, but cant find one.

many thanks for the help

Hey,

Did you found a good tutorial after all?

nope, havent found one :frowning:

The current installation guide will still work. You will need LAMP.
https://suitecrm.com/wiki/index.php/Installation

1 Like

I haven’t written a tutorial but here are some of my Ubuntu Server 16.04 install notes that will save you some time and give you some pointers:

Software selection on installation: LAMP, Samba, SSH

Get all modules quickly:
apt install zip unzip php-mbstring php7.0-mbstring php-gettext php-xml-parser php7.0-zip php7.0-imap php7.0-gd php7.0-curl sendmail phpmyadmin php-xdebug

Things to edit in php.ini:
nano /etc/php/7.0/apache2/php.ini
upload_max_size = 16MB (or bigger)
memory_limit=512M
fix error_reporting, add & ~E_STRICT
date.timezone = “Europe/Lisbon”

-also set timezone in the other php.ini of the CLI

/etc/init.d/apache2 restart

-copy files from SuiteCRM package into /var/www/html

cd /var/www/html
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php 

Now install the app via whatever address you have:
http://10.0.0.20/suitecrm/install.php

crontab -e -u www-data
add the folllowing line:

          • cd /var/www/html; php -f cron.php > /dev/null 2>&1
5 Likes

I’m gonna test them(the notes) right away (on virtualbox) before installing them on the work server.

pgr’s notes worked very well for me on Ubuntu 16.04.

Regarding line

I would like to add that directory “cache” and file “config_override.php” were present only after the SuiteCRM installer had run. On the first try as per the notes I got a warning regarding these items. Hence, I repeated this step after installation.

After permission change and before the browser-based installation routine, I had to create the SuiteCRM database manually. I.e. by these steps:
mysql -u root -p
CREATE DATABASE suitecrm_db;
CREATE USER ‘suitecrm’ IDENTIFIED BY ‘password’;
GRANT ALL PRIVILEGES ON suitecrm_db.* TO ‘suitecrm’@‘localhost’;
FLUSH PRIVILEGES;

Afterwards the web-based SuiteCRM installer ran as expected.

i wonder why you had to create that database user, but I didn’t need to… are you using MySQL also? Or MariaDB?

I use MariaDB. Whatever credentials / database options I used in the installer, it wouldn’t work.
After separate database preparation, the installer let me continue.

This is something that should be fixed, I believe. There must be some little difference in MariaDB causing this…