Installing on Centos Web Panel - Internal Server Error

I’ve installed this on a cpanel shared server. I get permissions problems with the “undefined” everywhere, but it does install. Now I’m trying to install this on a domain under the new (and completely awesomely free) web panel by centos. I believe I’ve sorted the permissions problems but I can’t check because I’m getting an internal server error and nothing else.

This is a VPS so I have full access.
basic setup
CWP runs on Centos 6.6
I’m running apache
php 5.4
csf firewall

I’m not a full time admin but i usually find what i need in linux. This one has me stumped and as cwp is so young there just isn’t so much documentation. Suite seems to have a Ubuntu fan base, most info I’ve found is for Ubuntu installs.

Before I can migrate from vtiger I need to know i can even install this. I’ve always had headaches with Sugar which drove me to vtiger, but that was a while ago now and vtiger is nearly completely focused on their paid platform.

So I’ve managed to screw up my groups and permissions settings so badly I can’t use my secure key login. Guess I’ll start over, but i’m pretty sure I’ll hit this same problem.

has no one encountered this “internal server error” and resolved it?

Fixed that but still permissions trouble.

Does anyone understand the permissions for this? I’ve read dozens of posts on permissions troubles, no real solutions though.

I guess i’m writing to myself…

SoftException in Application.cpp:564: Directory “/home/theright/public_html/crm/themes/SuiteR/css” is writeable by group, referer: http://.com/crm/index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView
[Mon Feb 01 10:39:16 2016] [error] [client] Premature end of script headers: colourSelector.php, referer: http://.com/crm/index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView
[Mon Feb 01 10:39:16 2016] [crit] [client] (13)Permission denied: /home/theright/public_html/crm/cache/jsLanguage/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:crm/index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView
[Mon Feb 01 10:39:16 2016] [crit] [client] (13)Permission denied: /home/theright/public_html/crm/cache/jsLanguage/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://.com/crm/index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView

This is indicative of my error log.

Of course the css in themes folder is writable by group, the install requires chmod 775 -R for the theme folder. Yet because it’s writable by group it can’t be accessed. this is from Chrome error console



http://.com/crm/cache/jsLanguage/Users/en_us.js?v=n-QTiOs2nqEOkkBrzs1Nug 403 (Forbidden)

I’m wondering if I can give my user.usergroup the rights of apache would solve some of the forbidden problems. Also, should I selectively edit permissions on files that trigger the softException?

Perhaps there’s an easier way of editing the policy in suPHP? I’m pretty sure cwp uses suPHP anyway.

I’ll keep looking, and hoping someone finds my lonely thread…

1 Like

I had this error as well. Did the initial chmod recursive, but it didn’t work right. Ended up changing the permissions of the following to 755 (no recursive, just these folders and the file):


suPhp is creating that error and shutting down the script before headers are sent (there is a header in that file). It (Apache) was denying colourSelector.php (and its path) ability to run while groups could write to the file and/or its path. This makes sense actually since suPhp is a runtime jail. So changing to a stricter permission works. You prob have to do this with the other themes too that use that colourSelector.php file.

Oh also, cache tries to set wrong permissions on new files. So if you are encountering 403’s for things like cached JS lang assets, you can try setting the default_permissions array in config (or config override) to use 755 and 644 permissions and use your accnt/group like so:

  'default_permissions' => 
  array (
    'dir_mode' => 493, // = 755
    'file_mode' => 420, // = 644
    'user' => 'myuser',
    'group' => 'mygroup',


look there :
and search for disable that… i have do that (sorry forget procedure but google is your friend ) and all is ok

Clear the cache and try again after restart the browser. See this guide:

Try this working guide

I am very enjoyed for this blog. Its an informative topic. It help me very much to solve some problems. Its opportunity are so fantastic and working style so speedy.