Installaton Crash

Using 7.1 then 7.2.2 installation every time I try to save the email settings the system crashes. Whether you try to save smtp settings on the install or skipping and setting later.

I searched the forum and have only found one related post to this but no suggestion on a fix.

I am running this install from softaculous on my vps.

I have also installed sugarcrm version and get the same result when configuring email for system or user.

Error that pop up on configuration
Strict Standards: Declaration of SugarEmailAddress::save() should be compatible with SugarBean::save($check_notify = false) in /home/siri123/public_html/crmSR/include/SugarEmailAddress/SugarEmailAddress.php on line 1113

Strict Standards: Declaration of Person::create_export_query() should be compatible with SugarBean::create_export_query($order_by, $where) in /home/siri123/public_html/crmSR/include/SugarObjects/templates/person/Person.php on line 44

Strict Standards: Declaration of User::retrieve() should be compatible with Person::retrieve($id = -1, $encode = true, $deleted = true) in /home/siri123/public_html/crmSR/modules/Users/User.php on line 44

Strict Standards: Declaration of User::create_export_query() should be compatible with Person::create_export_query(&$order_by, &$where, $relate_link_join = ‘’) in /home/siri123/public_html/crmSR/modules/Users/User.php on line 44

Strict Standards: Declaration of User::create_new_list_query() should be compatible with SugarBean::create_new_list_query($order_by, $where, $filter = Array, $params = Array, $show_deleted = 0, $join_type = ‘’, $return_array = false, $parentbean = NULL, $singleSelect = false,

Edit your php.ini to suppress Strict Standards warnings.



Hi Thanks for the response;

Are you saying to create ini file in the root and place code to suppress “Strict Standards warnings.”

Don’t have an ini in the public_html or installation root

Do have…/usr/local/lib/php.ini


Found it thankyou
actually changed display_errors = Off
in the ini


I have same setup & same issue- everything works OK until email set up.
Go to WHM (not cpanel) >service config- php config. Click on edit in advanced mode.
Scroll to error handling and logging- display_errors> turn off. I only had to refresh my suitecrm screen and then it was fine.