Installation Stuck at "License Acceptance" screen. Can`t Hit "Next"

I would like to install SuiteCRM, but am stuck to the step where you hit “Next” to proceed the installation.

I have already tried to change permissions according to the guide, but w/o success. Am I missing something? Expecially the following lines gives me a hard time determining how to do it right:

Set the following permissions on the SuiteCRM directory(Linux):
sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Here`s what I did (see attached pic) to set the root folder permission:

  1. entered the numeric value 755 and checked “Recurse into subdirectories” to apply to all files and directories.

  2. Afterwards, I did the same thing with the folders cache custom modules themes data upload and config_override.php, but this time with the numeric value 775.

I would greatly appreciate some help for less tech versed webmasters. Thanks

  • I use Windows 7
  • My hoster`s web server is Apache/Linux
  • the ftp program I use is Filezilla


Really need your help guys

Hi rosenberg,

The only other issue that may be causing this error is owner/group permissions. It seems you can only set these through an SSH connection. What is your exact Server/MySQL/PHP setup?



Hi Will,

sent you a pm. Please check your inbox.

Hi Will,

in an effort to dig deeper in order to find the root cause of the “can`t hit next” problem, I opened the IE debugger. (see attachement screenshot below)

As soon as I hit “accept” to accept the licence agreement, the red highlighted error command (see screenshot) “toggleNextButton is undefined” pops up, inhibiting me to proceed the installation by hitting “next”.

Now I seriously wonder how to wipe off this issue.

Any expert advice around here?

Thanks & take care

MySQL Host:

My hoster just said that they do not provide SSH access on their server.

What is your opinion? Would there still be a chance for a clean install?

managed to fix the issue with another hoster. Ipage isn`t compatible

1 Like

In my experience, best results are with a vanilla OS install where you can ensure the settings are correct for suiteCRM.

Very new to SuiteCRM. Just ran into the very same problem.

Also: No images showing so far…

Ok, got this now. Was somehow related to file permissions. On my server, after extracting the files, all the folders were set on 700. Changed all of them to 755 and it worked. Not sure which ones need to be 755 and which ones should be back on 700 though…

PRESS NEXT BUTTON…When u click accept