Installation problem. Install.php

When I type install.php in the browser window - I get no response. Apache is working and php is working. Created a 3 line script called phpinfo.php and placed it in the same directory as the install.php and this works. Which log file do I need to check if there are any error messages and to get more info?

Ensure permissions are set correctly. Check your php error.log and/or sugarcrm.log.

Hi, I have a similar problem. All permissions are set correctly, all services are running (WampServer icon is green, phpMyAdmin opens correctly and phpinfo works). The installer ran and I could get all the way with every step, and installation took place. I created a user called VicPro and set a password. Thereafter I had to forced the use of the password and all permissions seem ok. This was done during the installation process. Right at the end of installation I got an information page with the message: ‘Warning: mysqli_connect(): (HY000/1044): Access denied for user ‘VicPro’@‘localhost’ to database ‘suitecrm’ in C:\wamp\www\SuiteCRM\include\database\MysqliManager.php on line 282’ and now I see no way further. If I run the install.php again I get a warning that it is not a good idea unless really necessary. Is there a simple way to make progress?

Did you specify the correct credentials for MySQL? You should also suppress warnings/notices in your php.ini.



Edited the (2) php.ini files to include: error_reporting = E_COMPILE_ERROR, display_errors = Off, display_startup_errors = Off.
I am pretty sure that during installation the credentials were not correct and that this caused the warning. The question is what do I do now, given that it is not a good thing to rerun install.php and I can not see a way of getting further from here? There is no ‘Next’ or ‘Retry’ kind of button on the page with the warning.

Thanks for the help!

Delete the config.php file, this will re-start the install. Alternatively, unzip/upload a fresh copy of the SuiteCRM files.

Thanks for that, it worked perfectly for the installation. I got the message that installation complete, with the Next button. Then it stopped at another warning:

Warning: Cannot modify header information - headers already sent by (output started at C:\wamp\www\SuiteCRM\modules\Users\User.php:44) in C:\wamp\www\SuiteCRM\install\complete_install.php on line 4

I checked all privileges and they seem fine. What can I do next?


Still looks like you need to suppress warnings, as these should not be displayed!

Bravo! Went into php settings and set ignore errors. It worked.

Thanks very much for your help and patience.