Installation issues 7.9.1 on Fedora 25

I am trying to install SuiteCRM version 7.9.1 on Fedora 25. I have downloaded the latest files and placed them in an apache folder. I have ensured that both the user and group on all files and directories are “apache”. Also, I have made all files and directories have 755. I am getting the following error. These errors persist even is i change the permissions to 777 for everything. Can someone please let me know what I am missing? I have tried this on multiple Fedora 25 installations. Same problem. Any help is appreciated.

[color=#0000ff]Config override
The config override file exists but is not writeable. Please take the necessary steps to make the file writeable. Depending on your Operating system, this might require you to change the permissions by running chmod 766, or to right click on the filename to access the properties and uncheck the read only option.

Writeable Custom Directory
The Custom Directory exists but is not writeable. You may have to change permissions on it (chmod 766) or right click on it and uncheck the read only option, depending on your Operating System. Please take the needed steps to make the file writeable.

Writable Cache Sub-Directories
The files or directories listed below are not writeable or are missing and cannot be created. Depending on your Operating System, correcting this may require you to change permissions on the files or parent directory (chmod 755), or to right click on the parent directory and uncheck the ‘read only’ option and apply it to all subfolders.

Please fix the following files or directories before proceeding:

Writable Modules Sub-Directories and Files

Warning: Not Writable

Please fix the following module directories and the files under them before proceeding:
Writable Upload Directory

Warning: Not Writable[/color]

  1. The normal recommended permissions would be these:

    sudo chown -R apache:apache .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload config_override.php 

Please double-check if your web-server’s user and group is really apache:apache, otherwise this won’t work well.

  1. Also you could have a restrictive .htaccess file spoiling things.

  2. I also recommend changing the permissions in config.php like this

'default_permissions' =>
array (
'dir_mode' => 1533, // equivalent to octal to 2775
'file_mode' => 493, // equivalent to octal to 755
'user' => '<youruser>', // you must replace <youruser> with the actual value
'group' => 'yourgroup', // you must replace <yourgroup> with the actual value