Installation fails with database error (After every possible solution on the forum expended)

I’ve read all the articles I can find on the forum about this subject and they haven’t resolved the problem I have. The problem I have is that the installation fails due to “Database error” at the last. I’ve checked, re-checked, double checked and rechecked the permissions. Permissions are correct.

I didn’t create the DB in MySQL myself and left that up to the installation process to create and populate.

I have increased the memory in php.ini to 512 M

I have switched off Strict error reporting.

I have tried copying a fresh directory after the failure (And setting install_locked to false in the config.php)

I have tried installing 7.10 and 7.11 (not at the same time).

All of this and I still get exactly the same error :

Error creating table: : Query Failed: CREATE TABLE ( NULL ) CHARACTER SET utf8 COLLATE utf8_general_ci: MySQL error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘( NULL ) CHARACTER SET utf8 COLLATE utf8_general_ci’ at line 1

I have tried finding the .sql file and adding the ’ alter’ (But couldn’t find the offending line in the .php file masquerading in lieu of the .sql file).

Please help!

Hi, welcome to the Community! :tada:

Looks like you’re using MySQL v.8, which isn’t supported yet.

1 Like

Thanks for really fast reply! Whew! Ok, I’ll try downing the MySQL. Thanks.