INstall SuiteCRM vai command on my server

I want to learn how to download SuiteCRM from the command line.

The idea is to download SuiteCRM via command directly to the desitination folder.

I need to learn the commands to download the zip file to my directly. Can someoen help me with this command?

Thanks

Joseph

wget https://github.com/salesagility/SuiteCRM/archive/master.zip

1 Like

Thanks!

Which version does this download?Bleeding edge(development), or latest stable?

Thanks

Joseph

I think the master branch on Github is always the latest stable release (non-beta). At the moment, 7.8.1. But I’m not sure which branch they use for the betas.

You can also use this nomenclature to get directly to a specific release:


wget github.com/salesagility/SuiteCRM/archive/v7.8.1.zip

The full list with links is here: https://github.com/salesagility/SuiteCRM/releases

Making progress!

I downloaded the files as prescibed. But, a directory seems to be missing:

report upon tryign to install:

Writable Cache Sub-Directories

The files or directories listed below are not writeable or are missing and cannot be created. Depending on your Operating System, correcting this may require you to change permissions on the files or parent directory (chmod 755), or to right click on the parent directory and uncheck the ‘read only’ option and apply it to all subfolders.

Please fix the following files or directories before proceeding:
/var/www/clients/client2/web5/web/eau/cache/
/var/www/clients/client2/web5/web/eau/cache/images
/var/www/clients/client2/web5/web/eau/cache/layout
/var/www/clients/client2/web5/web/eau/cache/pdf
/var/www/clients/client2/web5/web/eau/cache/xml
/var/www/clients/client2/web5/web/eau/cache/include/javascript

the cache directory does to exist.

But, when I look at a downloaded, unzipped version of the install files, and cache folder is there, BUT, none of the folders match what is in the error report, so I can not even upload the missing folders.

I am stumped.

Ideas?

Thanks,

Joseph

The permissions on new files and folders are inherited from their parents. If you set everything correctly before installation, then the directories created afterwards should be ok.

Just follow the Installation Guide:
https://suitecrm.com/wiki/index.php/Installation

And make sure you don’t have your cron jobs running as root, that always messes up permissions.

Hello,

I posted too much information:(

The real problem is that the /cache/ folder is missing.

When I compare the error notes, and then I look at the unzipped 7.8.1 suitecrm that I downloaded, the cache folder contents are different. So, I cna nto even upload th same content from the 7.8.12 that I downloaded to my computer.

AS noted, I used the wget command to download theg suitecrm directly to my server. So, I downlaoded the latest version directly to my server. (7.8.1)

Thanks

Joseph

The cache folder doesn’t need to be there, it’s created when you run the installer. If you set the permissions right, every new folder that gets created will be ok.

Just follow what I said in my last post, and check the cron jobs, and then if anything goes wrong post here what the error is.

Hello,

I tried again today, and I get the same exact error.

The cache folder is missing, and it does not like it.

Where can I get a copy of this folder? I download a copy of SuiteCRM and it is not included.

Otherwise, how can I tell the installer that everything is alright?

Thanks

Joseph

Believe me, you don’t need a cache folder. You need to set your permissions correctly so these folders can be created. And the way to solve permissions problems for “future” folders that will be created is by fixing them in the parent folder.

I’ve asked you twice about your cron jobs (which user they’re running under) but you seem to have missed that question both times…

So, moving forward:

  1. Do you have your cron jobs (schedulers) set up? Which user are they running under?

  2. What exact commands are you using to set the correct ownership and permissions before running the installer? These are the commands found in the installation guide I linked above, applied to your specific system.

  3. What are the permissions and ownership like in the cache folders after the error? Command to see: tree -iudpf cache

Answer all 3 questions please.

Hello,

1 - I do have cron jobs, but only for SuiteCRM. They give you the entry to place in the cron jobs to keep things up to date. I have not added any other cron jobs on the server.
It is done usign root.

2 - As for correcting owner ship, I have had problems in the past abou tthis, and another user named “John” gave me the following to run inside my SuiteCRM folder:
sudo chmod -R 775 cache custom modules themes data upload config_override.php

It has always solved my permission errors.

3 - as for the permissions on cache, I mentioned that cache does not exist, but here is the result:

root@ISPConfig1:/var/www/ecol-o.net/web/eau# tree -iudpf cache
cache [error opening dir]

0 directories

It shows that I have no cache folder.

Ok…

  1. Your cron jobs should NOT be running as root. When they do, they create their own directories (mostly under “cache”) and these are not writeable by the normal app. Use these commands:

crontab -e -u root

(to remove the line from the root crontab)

and then

crontab -e -u www-data

(replace “www-data” by whatever your web server user is called, and insert the cron.php line in this crontab)

  1. The command you show is not sufficient to correctly reset permissions. Three commands are necessary, they are given in the Installation Guide I linked above (one chmod for ownership, two separate chowns for permissions).

  2. The tree command was meant to be run after the installer runs, when you have some directories under cache, but they are not writeable by the app. You should see a few entries there with root ownership or with degraded permissions.

I believe with this you will be able to install successfully. Good luck!