Install process gives validation error - no explanation

Fresh install in AWS Lightsail under Debian 10 , PHP 7.3. Install process after giving correct data, I hope, in form gives “There are validation errors…”. Well, where? No hints!
We have also tried CLI script installation giving another blocking thing. At some point the directory “cache/images” shall be created by mkdir in script but fails. We have tried to have full access rights for “world”.
So what shall I look for? The logs I find give no hints.

Hi Kenta, welcome to the Community :tada:

If the mkdir fails, that is surely a permissions issue. Here are a few possibilities you might try checking:

  1. If you have SELinux, try turning it off as a diagnostic
  2. About those world permissions: remember that permissions for new files depend on the parent directory and the SetUID and SetGID bits
  3. Have you been checking the web server log also? Usually php_errors.log, as defined in your php.ini
1 Like

Thanks. Your tips did not help but put me in another track. The CLI script must be run under sudo! At least in my environment in Lightsail.

Though, I am still confused why Web form not working.

This doesn’t sound too good to me, I fear that you might still have an unhealthy installation, where SuiteCRM is getting blocked from doing its work. You’ll just keep running into issues. By the way, if you see a bunch of labels showing as “undefined” in your UI, that’s a sure sign that ownerships/permissions/htaccess still need fixing.

Good luck, tell us if you get more info.

Installed another site yesterday. Out of that I ran install CLI script under sudo BUT them you have to adjust folder/file owners again to www-data (in my case).

What exactly doesn’t work when running the CLI installer without sudo?

I don’t know “exactly”. I have no screen shots.
Running CLI script without sudo fails. I dont remember now what
Running with sudo works fine.
But the access site the login page looks “limited”. The red login button has no text shown and is “thin”.
Changing folder/file ownership the login page looks normal. And from there good operation.

Yes, what you describe makes sense: running the installer with sudo will cause it to touch a bunch of files and create directories, all owned by root user. So you need to re-set the ownerships and permissions afterwards, to get back on track.

I would just like to know why running as sudo is required in the first place, but ok, I understand, you don’t have that information now. Thanks any way and good luck going forward!