Install fails with no .htaccess

Following the instructions in https://docs.suitecrm.com/admin/installation-guide/downloading--installing/ I get to the stage of calling the install.php file in the SuiteCRM subdirectory. I get the error saying:

Forbidden
You don’t have permission to access /FTLSuiteCRM/install.php on this server.
Server unable to read htaccess file, denying access to be safe

The error log says: …/home/xyz/public_html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/xyz/public_html/’ is executable

So, I created a blank .htaccess file in public_html, and still get the same error. The ownerships are the same as other applications on the same CentOS server.

Where can I look next for this issue?

Thank you – Tony

That’s not a SuiteCRM question, you’re better off searching for stuff online on StackOverflow or ServerFault about getting your permissions right.

  • find out which server your web server is running under

  • set ownership and permissions accordingly (don’t just use www-data because those generic instructions tell you to)

  • ensure the public_html directory is executable (which means, traversable)

This is on a CentOS server, and I had set ownership to accountID:accountID as is done for other applications on the server.

When I changed the bulk of the permissions to 755/644 (except those specified to be 775 in the docs), I could get the install screens. but the install fails with a missing install/status.json file, which is not in the 7.10.5 download.

Please use the permissions as proposed in the installation guide:

  sudo chown -R www-data:www-data .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod -R 775 config_override.php 2>/dev/null

Replace those users in chown with the account your web server is running under.

I don’t have a file called “install/status.json” in my 7.10.5 test system, already installed. I never heard of it either…

Do you have any other errors, namely in the web server log (usually called php_errors.log or errors.log)?

That is how the permissions are configured.

Nothing new on the error log. The visitor log shows install.php asking for /install/status.json every second.

To make sure that there were no cookie/sessions issues from earlier attempts, I restarted the browser. Again I got through to Step 2, and in the console I still see a stream of: Failed to load resource: https://XYZ.com/install/status.json the server responded with a status of 404 (Not Found)

I tried again, this time not checking any of the Site Security options.

The install worked fine this time. I will deal with those through the back end now.