Inline editing not doing anything in 7.3

Greetings all,

I’ve downloaded the 7.3 release by downloading the GitHub repository. It seems that inline editing of list and detail views is intended to be supported in this release. However, I don’t see anything in the readme for the release that suggests how to enable this functionality, or what the functionality is supposed to look like if it’s working. Is there anyone out there who has gotten inline editing to work, and can they describe how the functionality is supposed to behave?

Other than that, 7.3 seems to be working a treat for me.

Thanks for your thoughts.


1 Like

I’m having the same issue…

I noticed the following:

Line 46 - File: inlineEditing.js
Code as follows:
[color=#008800]var currentModule = module_sugar_grp1;[/color]

Error shown in browser after “debugging”
[color=#ff0000]ReferenceError: Can’t find variable: module_sugar_grp1[/color]

Line 441 - File: inlineEditing.js
Code as follows:
[color=#008800] var validation = JSON.parse(result.responseText);[/color]

Error shown in browser after “debugging” :
[color=#ff0000] SyntaxError: JSON Parse error: Unexpected identifier “There”
(anonymous function)

I’m attaching screenshots for better visibility (I hope they get attached)

Permissions -> checked (ok)
Disable, Rebuilt, Enable, Rebuilt -> checked (ok)
Still not working

Appreciate all help in advance

I got this working thanks to another kind forum post:

Thank you for the Reply, I reviewed and perform all steps in the provided guide, but still no luck.

Any idea somebody ?

Bumping this one up as exact same error showing, with a clean install.

Any other idea anyone ?


Nothing yet… I kind of gave up trying to troubleshoot… I made a lot of research, but still not working