Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Inline editing in 7.3

Hello All,

Just upgraded to 7.3 from 7.1.8 which was from SugarCRM 6.5.x.

It appears that Inline editing is now in production. However it does not work in my installation.

I also tried adding,

‘inline_edit_listview’ => true,
‘inline_edit_detailview’ => true,

to my config.php file but then SuiteCRM won’t load at all.

What am I missing?

TYIA,

~eric

1.) Go to Admin > System Settings

2.) Uncheck BOTH inline editing check boxes. There’s one for detail view and another for list view. (Save changes)

3.) Do a quick repair and rebuild

4.) Go back to Admin > System Settings

5.) Re-Check both inline editing check boxes. (Save Changes)

I found this in another post on these forums and it worked great for me. Give it a shot. :slight_smile:

3 Likes

Thanks Matthew,

Tried that, no joy.

~eric

I am having same issue on inline editing, Just upgraded to 7.3, I have the check boxes in the admin/ system settings, I does not appear to be active, using firefox

I, too, have upgraded from 7.2.x to 7.3.0. I have checked and unchecked the inline editing boxes in System Settings and performed many, many Quick Repairs, ensured the required config.php lines are set to True. The edit icons appear when I hoover over a field that is set for inline editing. The pointer changes to show that I am hoovering over a hyperlink. I have attempted to use inline editing in both firefox and chrome. However, the inline editing does not work.

I hope the community can provide a help with this feature as it appears most desirable. Thanks in advance.

Clear your browser cache.

You also need to double click on the field to actually edit it.

Thanks,

Will.

I opened in a new browser which has never been logged into SuiteCRM, Firefox, and still cannot edit inline.

~eric

Navigate to Admin -> System Settings. Uncheck, save, then re-edit, re-check and re-save the inline editing parameters/options.

Then Ctrl+F5 on the list/detail view and re-try.

Thanks,

Will.

Unchecked, Saved, Quick Repair, Checked, Saved, Quick Repair, Ctrl F5 = Still does not work.

Unchecked both in system settings and saved
Quick repair and rebuild
Check both in system settings and saved
Now it works fine for me (tested with chrome and firefox) if I’m logged with admin, if I’m logged with another user it dosen’t work even if I’m allowed to modify the data.

Have you tried clearing cache as the logged in user? Resetting their user preferences?

Yep, but it dosen’t change anything …

After walking through the installed files (post upgrade to 7.3) I noted that there were no files installed in the / Include / InlineEditing folder. Once I installed the .js and the .php files that were bundled in the upgrade package within the corresponding subfolder and set their preferences to 755, the inline editing work.

I’m not able to edit after my upgrade to 7.3, but I’m also not able to edit in the DEMO. I’ve tried all three browsers, but not sure if it’s a browser issue or upgrade issue?

Last time I looked the demo was version 7.2.0, which doesn’t support inline editing. That’s why you can’t get it to work. :slight_smile:

1 Like

I can edit, but when i want to save (data will be saved) the system give the warming:

Warning: Missing argument 5 for formatDisplayValue(), called in /usr/local/www/tmsservices/tmsscrm/tmsscrmcloudnl/V73/include/InlineEditing/InlineEditing.php on line 332 and defined in /usr/local/www/tmsservices/tmsscrm/tmsscrmcloudnl/V73/include/InlineEditing/InlineEditing.php on line 337

line 332: $value = formatDisplayValue($bean, $bean->$field, $fieldlist[$field], $method);
line 337: function formatDisplayValue($bean, $value, $vardef, $method = “save”, $view)

[quote=“MatthewJones” post=21778]

Thanks

Ok, in list view, it works, but in detail view, I’m not able to edit via the double-click.

Thanks for any help.

I work with a LAMP stack (internet provider) . Found out in the past that after update some things don’t work good. Fields that apear but not clickable. Changes in layouts with Studio: hard to save (sometimes I had to do it three times) and so on. Look at all topics: always problems with updates (also with SugarCRM by the way). During update the specs you need are higher than normally. Maybe that’s a source of problems. Therefore I give everyone a strong advice: always install a fresh (new) instance. A bit more work in the beginning but bottom line an better result in less time.

Transfer your old changed layouts to the new environment (with Studio & module loader) and test everything very good before you use the new version.
If you have modules installed, you should do that again (to change the CRM maps of the new installation).

My problem is different. I have installed a fresh new version and I CAN use online-editing but when I save the field I got a warning in that field: see bolow
Anyone an idea?

Warning: Missing argument 5 for formatDisplayValue(), called in /usr/local/www/tmsservices/tmsscrm/tmsscrmcloudnl/V73/include/InlineEditing/InlineEditing.php on line 332 and defined in /usr/local/www/tmsservices/tmsscrm/tmsscrmcloudnl/V73/include/InlineEditing/InlineEditing.php on line 337

line 332: $value = formatDisplayValue($bean, $bean->$field, $fieldlist[$field], $method);
line 337: function formatDisplayValue($bean, $value, $vardef, $method = “save”, $view)

Just did the upgrade followed instructions on getting the inline editing to work, unfortunately, everything up to double clicking the edit icon works. When double clicking on the edit icon for inline editing II get the following errors in Chrome using the inspection tool…

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check http://xhr.spec.whatwg.org/.

index.php?action=ajaxui:1 Uncaught SyntaxError: Unexpected token T
getValidationRules @ inlineEditing.js:441
(anonymous function) @ inlineEditing.js:105
n.event.dispatch @ sugar_grp1_jquery.js?v=-w0Elw0DmJ2mSPegXSje9w:1
n.event.add.r.handle @ sugar_grp1_jquery.js?v=-w0Elw0DmJ2mSPegXSje9w:1

Hope this helps