Inline editing does nothing


I am using suitecrm 7.3.1 on ampps under Win7 with a current Firefox. When I double-click on the pencil either in the list view or the detail view nothing happens. Firebug gives some more infos where the problem lies. Please have a look at the attached picture.



Have you ensured that your permissions are set correctly?
You will also have to ensure that your owner/group user is correct too.

If both are correct, Do your suitecrm.log or sugarcrm.log files show any errors?

Regards, John

I get the same error on my remote server. However, on my local machine I downloaded 7.3 version and inline editing works. I think the upgrade script is missing something, it looks like it has something to do with ajax and jquery.

After upgrading to 7.3, you may need de-activate/re-activate Inline Editing for it to take effect;
Go into Admin > System Settings,
There you will find the options “Enable inline editing on list view” and “Enable inline editing on Detail view”. Uncheck both of these and save settings.
Then go back into Admin > System Settings and check both options again. After saving system settings again, do a Quick Repair/Rebuild.


Thanks John, I did that already but to no avail.

A simply way to solve my problem is to set “display_errors = Off” so no notice message is displayed.

It would be better to check the array indices before accessing an undefined index. So instead of

it should read


So inline editing works now for me but there is definitiv another error. When I tried to save by clicking on the green check mark I get this error:

Warning: Missing argument 5 for formatDisplayValue(), called in C:\Program Files (x86)\Ampps\www\suitecrm73\include\InlineEditing\InlineEditing.php on line 332 and defined in C:\Program Files (x86)\Ampps\www\suitecrm73\include\InlineEditing\InlineEditing.php on line 337

You only have to look at these two lines and one could easily spot the problem:

$value = formatDisplayValue($bean, $bean->$field, $fieldlist[$field], $method);

function formatDisplayValue($bean, $value, $vardef, $method = “save”, $view)