Inline edit on Listview not updating and erasing field

Im running SuiteCRM locally: Windows 7, Apache, PHP 7.x, MySQL, SuiteCRM 7.11.8.

Here is a screenshot of my Listview for the Contacts module (renamed to Clients):

The hours with client field is the field with this issue. Whenever I try to edit the number, it does not save the entry and erases the previous entry as well.

Hours is a custom integer field with default: 0, min: 0, audit checked, and inline edit checked.

The other fields are working correctly.

Please try a couple of things

  • check for JavaScript errors in your browser’s developer console when you edit the field

  • maybe rename the field so it doesn’t contain any spaces - see if that changes anything

The field is actually named hours_c, but I tried changing the display name anyway to have no spaces. Still have the same problem of the field disappearing and not saving.

Here is my console when trying to edit the field inline at the Listview:

What is the data type of your custom field?

Can you please try reproducing this in this live demo, so we can see if the problem is only in your installation?

It allows admin access, so you can add the field in Studio.

The data type is int(255).

I tried an inline edit of it in the demo from the Listview, and it works, so I suppose it is unique to my installation.

By the way, am I using the term ‘inline edit’ correctly? Like, does the ‘inline edit’ option in Studio->…->Edit Fields refer to this?

Inline edit is when you double-click to edit a single field directly in Detail or List views, without entering the Edit view:

And yes, in Studio / Module / Fields you have an option to enable/disable this for individual fields.

I don’t know how to solve your problem. Maybe I would start with some repairs from Admin / Repairs

  • QR & R

  • anything Javascript relate

  • rebuild Relationships

I realized my mistake. It shows as an integer in Studio… but I edited the list view in code rather than in Studio, and I added the field as an enum rather than an int… :oops:

Ok… stuff like that happens!

I’m glad you got it working! B-)