Inline Edit of Cases Status not working

Hi all,

First of all: Great work, great product!

When viewing all of my cases in list view, I can edit ‘State’ inline. This does not work for ‘Status’ as the little hook symbol is not shown.

Running SuiteCRM 7.9.5, it’s the same issue in Firefox as well as in Chrome. Chrome’s console shows two errors, please see the attached screenshot.

As I am not familiar with JS coding, is there any way for me to pinpoint the issue?

Thanks and best,

If you have trouble uploading screenshots here (it happens), upload them in Pasteboard or Pastebin and then post link here.

I tried inline editing on the Cases Listview, and I find that I can’t do it by single-clicking the pencil icon, but I can if I double-click anywhere over the value.

Both things should work, though. Does double-clicking work for you?

Then you have to finalize by clicking the “check” mark on the right of the value.

Hi pgr,

Thanks for your reply! Indeed the “Add File” button is not working for me (latest Chrome on Ubuntu 17.04). Even worse, my posting was not listed under “My Topics” so I could not add the missing screenshot. Now I am irritated that I cannot edit my first posting.

Nevertheless, this is the aforementioned screenshot showing the JS error. I use double-clicks to open the status dropdown in list view.

The actual issue is the missing check mark. With other fields I do have the check mark and it works. Screenshot from detail view showing a working “state” dropdown and a missing check mark for “status”:

Thanks and best,

The check mark should only appear when you are inline editing that particular field. In your screenshot, you’0re editing the other field, so the check mark in status isn’t shown.

Does it show when you double-click status? Look for it at the far right, sometimes it’s distant from the field.

“State” is working fine on my installation. I learned from the online demo at that “Status” should work the same.
I combined those two edits into one screenshot, sorry if that was misleading.

“State” works fine (dropdown and check mark):

Double-click on “Status” opens the dropdown but no check mark is shown anywhere:

Any idea what the JS error in Chrome’s console mean?
I tried literally all repair actions in the admin section to rule out any manually modified files. I am afraid I might have undocumented changes from adding bug fixes I read about on github.

I’m sorry, I also don’t know much of Javascript.

What are those “404 Not found” errors? Is the browser having trouble loading some file? Permissions issues perhaps?

Apache’s access.log indicated a missing file called SugarFieldDynamicenum.js. I searched for it and found a copy at suitecrm/custom/backup/custom/include/SugarFields/Fields/Dynamicenum/SugarFieldDynamicenum.js. After copying the file to the expected place the 404’s disappeared.
Quick edit for case “Status” is not working yet, showing the following error in Chrome’s console.

Now it seems to be a purely JS-related issue.

Frankly I don’t know how to approach this issue.

I see some action on Github regarding “eval” which comes up in your errors, but I can’t tell if it’s related.

I copied the whole VM to have a test environment. There I unpacked the latest suitecrm version, copied my config.php, imported my customizations as a previously exported module, leaving the DB untouched. Magically the issue disappeared, so it’s not a general issue. I will probably do this on our production system in a couple of weeks when some issues that affect us are closed on github. Still I am a little worried that this procedure could have some side effects.

Thank you for your efforts.