Inline edit doesn't save relate field

Hello, community

I’d create “relate” type field named “Occupation” which relate my custom “Occupation-category” module (second screen)
My issue: inline edit doesn’t work i try to write a value
In first screen i try to write “59” and next

On the first screen, I try to write “59” and then if I select any value from the list and try to save (confirm the changes on the right and then click save button on the top panel) Then page will saved and refreshed and new data will not change; it will remain the same.

It is worth noting that this method works in editview
Also, Inline edit works in the field above. (There is also my custom create "relate"type field but it is relate witn “accounts” module).
Also Inline edit works well I select a value from popup)

Tell me what I did wrong? Any tips how can i fix this Inline edit issue?
My suitecrm version 7.11.10

How did you create such field? Through studio or by hand?


thanks for your reply

I create all files only through the studio

Half solution: use one-to-many relationship, so it works correctly

But I would like to ask another question here :
As you can see in the first screenshot after the numbers come the names,
how can I improve the quick search?
so that I can enter names without entering numbers?
for example, I’d just like to write “Assembly" and that all fields with this inscription “Assembly” would appear in the list, for example “51-1011.02 Assembly”

Try “Assembly%” or “%Assembly”.

And search these forums for search_wildcard_char and search_wildcard_infront configs.

1 Like

Thanks for your reply

I found your post about this, is any news about fixed this bug?
(I also use congif search_wildcard_infront it’s doesn’t work for me)

You’re using Elastic Search?

i’m not use
Should I install and connect it? will this fix my problem of searching in fields?

There are 3 search systems: basic, advanced, elastic. These refer to the global search on the top-right menu in every screen.

If you’re just worried about the behaviour of find-as-you-type inside related fields, that’s completely different. You’d have to customize code. That system is called “sqs”, you can search these forums for some threads related to this.

Hello sir

Could you look at 1scrensho?, the area highlighted in a red circle is a drop-down search list
My problem is that in this (and other) fields I have to write the “%” symbol before the search word, how can I make it the default and not write each time?
Tips in other topics on the forum do not help me, i mean params search_wildcard_char=% and search_wildcard_infront=true in configs file.

And the second question is, when I am write something in the this field, should I stop at least for a second and it’s turn on the autocomplete line from the first value in the drop-down list
how can I turn off this autocomplete?

For that thing marked in red in your screenshot, this applies:

Also, another thing that can be confusing: your browser might also be creating a “find-as-you-type” behaviour in any field.

You can tell the difference because your browser will only remember values you previously typed in that field; whereas the SuiteCRM SQS search will find any related value in the database, even if it hasn’t been used before.

If you are not a developer, I don’t think you will be able to get any different behaviour here… it really requires coding.

1 Like

I almost figured out the issue of disabling autocomplete.
This code in editviewdefs.php in modules/ (module) /metadata/editviewdefs.php Make autocomplete disable for selected text field. But it’s only work for editview and doesn’t work for Inline Edit.
So is my question is how can i make it for Inline edit too?
Also how can i disable autocomlete for all text fields in my suitecrm system? but not for each text fields individually?
array (
‘name’ => ‘assigned_user_name’,
‘label’ => ‘LBL_ASSIGNED_TO’,
’displayParams’ => array (
’class’ => 'sqsEnabled sqsNoAutofill’

And I apologize for asking the next question again.
I think that these parameters search_wildcard_infront=true in configs file do not work for me.
I still have to enter the % character manually each time.

These are only supposed to work for Global search, on the top-right of your screen. They are a completely independent mechanism from the SQS completes in related fields.