Increasing text field

I have a field I increased from 4 digits to 10 digits. I check the DB and the field is now 10 characters. If I edit a record, or create one it accepts 10 characters. However, if I “quick edit” the field by double clicking on it, it only allows me to enter 4 digits???

Is there somewhere different the quick edit gets it’s field information from?

I’d start by trying the Admin / Repairs:

  • QR & R, scroll down to the bottom, if there is a button to sync vardefs, press it

  • any other Repairs that are related to Javascript

Thanks PGR, I tried QR&R, did all the JS rebuilds. No luck. It’s weird that it only effects in line editing and not when a new record is created or a record is edited. As a work around, I might just create a new field with the correct length if I can’t figure it out. I also tried removing it from the view and adding it back. No luck either.

I still think you have something stuck in a cache somewhere, but if you already tried the repairs, I don’t know what else to advise… like you said, you’re left to creating a new field :frowning:

Okay so I had the exact same issue, QR&R does nothing, in the studio it was the correct length, but like the author in inline edit view it was the default length value (in my case : 100).

To fix this :

go in /cache/include/InlineEditing/ and search for the field that have this issue, edit it and you just have to put the correct maxlength=‘xx’.

Your done ! :smiley:

Dont know why it doesnt work and from where the bug is coming, checked my permissions everything was correct.