Incoming Email doesn't work

Hi guys!

This is Erick, and i am facing a problem which incoming email function doesn’t work.
outgoing works properly.

in the setting, there three folders

Monitored Folders: *
Trash Folder: *
Sent Folder:

There is no respond, when i try to specify these three folders. test setting is also no respond at all.

what am i supposed to do for fix it, and let it work properly?

my version is 7.2.1

1 Like

Have you tested the inbound mailbox using the test settings button? Does the test return successfully? Are these settings working elsewhere?



Hi Will,

I have the same problem as Erick have with incoming mail, i realy can not make it work, my version is the same 7.2.1


I had this issue and after going through the documentation i worked it out. Basically, when you look at the core SugarCRM documentation, you can see that the “CHECK MAIL” manually button is completely disabled for group email. IE, it can only occur via a scheduled task.

If you added a personal email, you would see it working fine… technically the CHECK MAIL button (and the corresponding “manual” option), only works on personal accounts.

You were probably puzzled like i was that the account connected and was authenticating just fine but no email was being added and no cases created. Naturally I assumed it was a bug, but it was just weird SugarCRM logic that Suite inherited, (and is rather poorly documented by Sugar in the first place).

if you go to scheduler | inbound email. You can see this will state “never” next to being run. I noticed one of the screenshots on this forum showed a windows instance with localhost in the taskbar, you gotta setup windows scheduler for windows. Otherwise just try triggering the cron manually via commandline on linux and then add it to crontab as your permanent solution.

Happy Suiteing.

I had problems configuring and testing Bounce mailbox in 7.2.2. The test cycle ended before using ‘/ssl/validate-cert’’, interpreting ‘IMAP connection broken’ as ‘wrong user ID or password’ and ended test. The solution was to comment out line 2441 in /modules/InboundEmail/InboundEmail.php (see below)

            if ($errors == 'Too many login failures'

// || $errors == ‘[CLOSED] IMAP connection broken (server response)’ <-----
// @link
|| strpos($errors, ‘[AUTHENTICATIONFAILED]’) !== false
// MS Exchange 2010
|| (strpos($errors, ‘AUTHENTICATE’) !== false && strpos($errors, ‘failed’) !== false)

After this, a connection could be established using ‘/ssl/validate-cert’’.

Hi Jeremy,

I have been googling for hours because i couldn’t get the group imap inbound email working, the Test Settings button said everything was correct but no email showed up in the group email box, in fact the folder structure doesn’t even show in the SuiteCRM email screen (but i CAN select all the folders in the IMAP setup screen so it connects!). Your post made me try and setup a personal email account with the same settings i used before with the group account and now it works! So obviously the SuiteCRM server can connect with my IMAP account but for some reason the group email function isn’t working.

You say i have to setup the cron but my cron job is already configured. I’m still not getting any emails into the group account. I don’t get it…

This hack fixes SSL IMAP Authencation. Your hack has allowed me to connect via ssl imap. thank you so much. Before i use to get invalid username or password and could only connect via regular imap. The issue of receiving mail is still at large and I don’t even see the inbox really, i can only send mail. Has anyone solved this matter.

Im having the same issue with 7.3.2. Im having this error Login or Password Incorrect. Is this a permanent bug or did somebody have a fix for this issue. Kindly help us.


We have figured out the problem. by commenting the other ssl parameters in /modules/InboundEmail/InboundEmail.php staring in line 2370

$ssl = array(
/‘ssl-both-on-secure’ => ‘/ssl/tls/validate-cert/secure’,
‘ssl-both-on’ => ‘/ssl/tls/validate-cert’,
‘ssl-cert-secure’ => ‘/ssl/validate-cert/secure’,
‘ssl-cert’ => ‘/ssl/validate-cert’,
‘ssl-tls-secure’ => ‘/ssl/tls/secure’,
‘ssl-tls’ => ‘/ssl/tls’,
‘ssl-both-off-secure’ => ‘/ssl/notls/novalidate-cert/secure’,
‘ssl-both-off’ => ‘/ssl/notls/novalidate-cert’,
‘ssl-nocert-secure’ => ‘/ssl/novalidate-cert/secure’,
‘ssl-nocert’ => ‘/ssl/novalidate-cert’,
‘ssl-notls-secure’ => ‘/ssl/notls/secure’,
‘ssl-notls’ => ‘/ssl/notls’,
‘ssl-secure’ => ‘/ssl/secure’,
‘ssl-none’ => ‘/ssl’,
leaving only ssl-none.

We can now connect to our mail server

Hope this could help


thanks for reply. @thunder4dog, your solution still doesn’t work with me. Do you have any other idea? thanks

In my case it works. Thank you thunder4dog.

I configured all set up for inbound Email.

But I didn’t recieve any mails, instead of this all mails going Out bound configured mail id.

What to do for recieve mail?

Please help me

you need server access and seting up a cron job.

Thanks for your reply…

I done cron job and it is running every 5 minutes.

But still getiing out bound mail id only receive mails.

What is the diff between out bound & inbound mail ?

Outbound = sending email
Inbound = getting email


For me inbound also mail sending

I want to send & receive email for lead creation .
Is this possible?

removing the code from the inbound php files didn’t work form either
Still struggling with this basic thing.