Income Mail configuration issues after upgrade to SuiteCRM 7.13

Hi, I have separate instances of SuiteCRM both experiencing the same issue after upgrading to version 7.13.

I need to use port 7993 instead of 993 for my particular setup. It was configured and working properly under 7.12. After upgrading to 7.13 the port get changed from 7993 to 7,993 (a coma is added).

This has broken my incoming email. Please see attached screenshots. As you can see by the screenshots the
Connection Test is successful before I save the settings (using correct port 7993). However as you can see on the 2nd screenshot, after I hit save the port is changed to 7,993 and the connection fails.

Any idea what is going on here?

hed images


Thank you for raising this

I’ve given this a quick test locally, and it does appear to be an issue with the new Email Module.

It looks as though the field is set as an “int” in the Vardefs, so will be trying to add the Thousands seperator:

I haven’t tried this myself, so I can’t guarantee any success
but you could perhaps try changing the field type set in the vardef above.

(or creating a new one in the /custom/ directory, to be upgrade safe)

and seeing if this resolves your issue?

Either way, would you be able to raise this on our Github Repo as a bug?:


Hi Thanks for your help.

I changed the type from int to string and this solved my problem. I don’t know code so if this is not the appropriate type, please let me know.

Thanks again for your help, this was driving me nuts.

I’ll create a bug report on GitHub.

I’m glad that helps!

Thanks for raising this.

Here’s the link, for anyone who may come across this thread in the future:

In regards to the type

I think your best bet would likely be either:

'type' => 'text'


'type' => 'varchar'

As these are the two types that SuiteCRM typically uses for text-based fields.

Thank you, I appreciate this.