Inbound emails visible by all users


I’ve got latest (7.11.10) SuiteCRM, updated from LTS version. I’m trying to setup inbound email accouns, however I’m facing some problems. My setup is as follows:

  • I’ve got 3 users, on e admin, 2 normal. Each have one inbound email account configured and working
  • I’ve got 1 group mail account that I want to be visible to only some users (for now admin and one normal user)

However each user can access (by selecting account/folder on EMAILS page) any one of existing email accounts in system (personal or group), which is definetly not what I want. Additionally, when I edit user profile, click “Settings” under “Email Settings” and try to select allowed folders under “Folder Management” always all 4 accounts are selected. If I click on any position, even “—None—”, it is selected as single briefly and quicky returns to 4 accounts selected.

What am I doing wrong? How to make “Personal” emails really personal (or maybe also accesible by administrator)? And how to make group account available only to certain users?

Did you figure this one out? I have a reverse issue where I can’t add the group email to any users but very similar behavior. Clicking none have them show up and then it disappears

Hi @Kaphis,

Are you using a newer version? As these issues should have been resolved

Unfortunately it is not solved, at least I and some more users could not figure out how it works as well.
There is another thread discussion here with the same issue: