Inbound email setting giving error.


I am using SuiteCRM 7.6.4.

When I try to setup inbound email and “Test Settings” after filling email details, it always gives error below error :

"Can’t connect to,993: Network is unreachable

Please check your settings and try again."

Please suggest how can I resolve this.


(you haven’t updated for over two years, and you are more than 40 releases behind… there were literally hundreds of security fixes and bug fixes…)

About your error, it sounds like a network problem. Maybe try Firewall configurations, or simply removing the Firewall temporarily to see if it makes a difference,. Try also turning off any anti-virus programs.

Also check DNS configurations and try pinging from the server’s command-line.

Hi, I have version 7.10.7 and also the previous one and the same thing happens. It is not possible to set up an incoming Gmail account.

In other versions I have done it without problem.

I already checked in the Gmail settings that this IMAP is enabled and also that it allows unsafe applications, but the problem continues.

Please someone who can help us.

Thank you.


1 Like

Maybe you have to check the security settings on google? There is a setting somewhere to allow “unsafe” apps to your account.

I had this (with another integration) in the past.


I am trying with other details but still giving below error.

[CLOSED] IMAP connection broken (server response)

Please check your settings and try again.

suitecrm.log is displaying below errors in it :
Tue Jul 17 09:04:32 2018 [22208][1][FATAL] Exception handling in /home/shirtwor/public_html/suite/include/MVC/Controller/SugarController.php:402
Tue Jul 17 09:04:32 2018 [22208][1][FATAL] Exception in Controller: SugarFolder::retrieveFoldersForProcessing() Cannot Retrieve Folders - Please check the users inbound email settings.
Tue Jul 17 09:04:32 2018 [22208][1][FATAL] backtrace:
#0 /home/shirtwor/public_html/suite/include/SugarFolders/SugarFolders.php(612): SugarFolder->retrieveFoldersForProcessing(Object(User))
#1 /home/shirtwor/public_html/suite/modules/Emails/EmailUI.php(3125): SugarFolder->getGroupFoldersForSettings(Object(User))
#2 /home/shirtwor/public_html/suite/modules/Emails/EmailUIAjax.php(1326): EmailUI->getShowAccountsOptions(Object(InboundEmail))
#3 /home/shirtwor/public_html/suite/include/MVC/View/SugarView.php(840): include_once(’/home/shirtwor/…’)
#4 /home/shirtwor/public_html/suite/include/MVC/View/views/view.classic.php(74): SugarView->includeClassicFile(‘modules/Emails/…’)
#5 /home/shirtwor/public_html/suite/include/MVC/View/SugarView.php(207): ViewClassic->display()
#6 /home/shirtwor/public_html/suite/include/MVC/Controller/SugarController.php(432): SugarView->process()
#7 /home/shirtwor/public_html/suite/include/MVC/Controller/SugarController.php(375): SugarController->processView()
#8 /home/shirtwor/public_html/suite/include/MVC/SugarApplication.php(109): SugarController->execute()
#9 /home/shirtwor/public_html/suite/index.php(52): SugarApplication->execute()
#10 {main}

I have tried the email details by setting up latest version of SuiteCRM on same server. It is giving same errors.

Please suggest.

When you “Send test email”, if it fails, it gives a link to show “Full SMTP log”. What does it say there?

Full SMTP log saying :

3: Connection: opening to ssl://, timeout=300, options=array (
3: Connection failed. Error #2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [/home/shirtwor/public_html/suite/include/phpmailer/class.smtp.php line 299]
3: Connection failed. Error #2: stream_socket_client(): Failed to enable crypto [/home/shirtwor/public_html/suite/include/phpmailer/class.smtp.php line 299]
3: Connection failed. Error #2: stream_socket_client(): unable to connect to ssl:// (Unknown error) [/home/shirtwor/public_html/suite/include/phpmailer/class.smtp.php line 299]
1: SMTP ERROR: Failed to connect to server: (0)
3: SMTP connect() failed.

Well, with this information you should be able to find out what’s wrong. I am not a phpmailer expert, nor an SSL email expert.

But you can Google for these errors and see what needs to be done in your email configuration.

This doesn’t look like a SuiteCRM problem… even if you tell me it’s working with other programs - your server is expecting something different from what phpmailer is giving it, but phpmailer is a very standard piece of software - maybe some options can be tweaked to make it work.