Inbound e-mail to Cases

Hiya, I must be missing something somewhere.

I have set up an email account on ‘Inbound Email’ to be able to create cases. It tests ok and appears in my ‘All Email Accounts’ as type ‘group’.

It even appears in ‘My Emails’ but greyed out and in Italics.

When I send e-mails to it, no cases are created. Is this because the group is not assigned to a user?

The manual says this for the new inbound email:

In the Assigned to Group folder select the group folder you wish to use. If you do not have a group folder or need to create a new group folder:

Click the Create button.
Enter in a new Folder Name.  For example, Support Emails.
Click Save.

… but I get no such options when creating the inbound e-mail

Hi Steve,

Are the emails being imported, and hence visible in the group email inbox?
If not, did you set up the scheduler script to run as a cron job (*nix) or as a Scheduled Task (Windows)?

Did you confirm that the Check Inbound Mailboxes scheduler task is active?
Then click on Check Inbound Mailboxes to view the scheduler’s run history.



I have the cronjob set up and appears to run every minute.

Where/how can I see the Group Inbox? I have not specifically set up an inbox just the Inbound Emails from the Admin page.


Based on the screen shots you uploaded earlier, click on the italicised “Forest IT” and you should see emails that have been imported but not converted to cases.

If they were converted to cases, the email appears in the inbox of the assignee instead.

See attached screen shot that shows a job log of each Inbound Mailbox check. You will only see rows in the Job Log if the job being run by cron is executing successfully and this scheduler is Active.

Thanks for that, I had enabled the AOP inbound email instead of the generic one.

That is now running, but never completes successfully

Here is the sugarcrm.log entry.

Hi Steve,

Can you test your mail server and validate it accepts IMAP connections first and then check the port (secured or unsecured) you are attempting to hit it on?

Edit: also if using fqdn make sure it resolves from the SuiteCRM Server.


I’ve done a Test Settings on the Inbound Email setup and that’s fine, I use Office365 e-mail and I’ve also changed it to a gmail account and both check out ok.

Do I need to set up a user on SuiteCRM that has the same e-mail address as the automated one so that the emails have somewhere to go?

If you want to deal with the incoming emails in the Email module you will need to stop auto case creation on the Inbound Email account. If case creation is turned on nothing will show up in the Email module associated Inbound Email account (in italics).

The mailbox that is being monitored is a 365 users actual mailbox which I think you have working. I use one for support and its attached below so you can see how I have it setup. Hope it helps.

Turn off case creation and you should be good.