Import records - Error: Invalid date string


I tried several times, with different date formats, to import a csv file with a date field. The message is always the same. The original file has been updated to date format, not text.

What am I doing wrong?



At Step 3, hit view import file properties and specify the date format your data is using

1 Like

Thanks for the tip.
I did it but the result is the same. I tried to save csv with date field as date format but, after saving, it converts the data again to text format. For example: 23-10-2014 becames '23-10-2014. And I get the error message again.

Thank you.

I wonder what was the fix for this as I am having the same issue?

As I stumbled upon this problem myself, let me leave the resolution for the future:

  1. Check date format for the date and date/time columns in notepad
  2. Import file to Suite CRM
  3. In step 3 click Import file properties and change settings of the date according to the date format in your csv file (if necessary)
  4. Import :slight_smile:

No. 1 is important because what you see in Excel/Calc etc is not necessarily how the date is actually stored in file.