Import record update problem

Installation is on MS Server 2008,PHP 5.3 and 2008r2 SQL.

Issue: After importing records, in our case ACCOUNTS and CONTACTS,it will not allow us to add notes to any of the imported records. What happens when you click on CREATE NOTE OR ATTACHMENT in the subpanel, AJAX will not load so it renders as html. From experience in the past, anytime I see that behavior the note will not be saved. After some tinkering around I noticed by clicking on EDIT and APPLY on the imported ACCOUNT or CONTACTS record it will let me add a NOTE successfully from the subpanel. This can be repeated every time. It appears some type of trigger is not occurring after the import to apply the records to the database. What I don’t want to do is have to hit edit and apply on a thousand records. Any insight would be greatly appreciated. Also if I add an ACCOUNT or CONTACTS record manually it will allow me to add a NOTE without problem. This only happens when importing.

Hi lle,

Thanks for highlighting this. We will look into this issue.



It looks like I was not accurate in my remarks. Even if I add an Account manually, it will allow me to add a note the first time but all subsequent attempts to create a new note in the HISTORY subpanel will only launch with as HMTL and not AJAX. At that point the note will not save. I have to click edit and apply on the account record in order to add another note.

Hi lle,

I have tested the functionality mentioned in your last post. I can add several notes in the History sub panel without fault. This may be a MS Server/MSSQL specific error. What browser are you using? Do you have any errors in your sugar log?



Unfortunately nothing records in the log. I have tried IE10 and Firefox 25. I have also tried it on MS SQL 2008 and MSPorted MySQL 5.1. I’m running PHP 5.3. This behavior is also occurring in SugarCRM 6.5.16.

I’m wondering if a it is meant to run under a Windows port.

One thing I do notice is once I hit Edit and Save, btw this happens in every module, I can then add as many notes as desired without a problem. It seems to only happen when I first go into the module but after hitting Edit and Save, it will allow unlimited addition of notes for the specific module. If I go to another module the same process has to be repeated.

As an additional note this is actually happening on all subpanels not just notes. As you indicated earlier this is something happening system wide and perhaps it is a database issue. I put the logging into debug mode and it is attached. The only thing I see is mention about email and not being able to retrieve some pictures?

Please disregard this post. I’ve installed everything on Linux and it works fine. I’ll use this environment going forward.