Import column format errors

We recently updated our version, and completed a full system restore, as part of the restore well exported all the data from all the modules with the intentions of importing the information after the restore was finished. I have tried to import the main module information and the import only takes in 28 records and there are a test import with 50 records in it, I have tried with 11 records and the import found 15, on the third attept I tried to import 60 records and again only 28 where accepted for import. The format of the information is as it was exported and as a CSV file,.
The import only ever creats about 6 to 8 records and find errors with the format of the other records. The errors are wrong format date, Value not in dropDown list, Invalid Email address & ID given is too long to fit in the field (maximum length is 36 characters) and some more but the Information is correct until it starts to import when the information from columns to the right move over to the left, e.g. last name field is filled with area code info, email field is filled with social welfare number, the info jumps to the wrong field but the next row will be imported without any issue or the wrong info will save into the field and the record will be corrected with all the wrong information saved in the wrong field.
I don’t understand if the export came from the system, why won’t the restored system accept the information. I hve 3500 plus records that I don’t want to have to manually input and the relevent submodule information that needs to be imported as well.


Ok. Lets break this problem down and see if we can tackle it in steps.

You’ve exported as a CSV. Ok cool, How are you opening that file? In excel, or another software? How does it ask you to “separate” the data. By comma? double quotes?

Regards to the invaild dropdown values, there must have been a change in the past where a value existed and then removed. Obviously that maybe a problem when importing it back in. Do you know if any of these dropdowns have a default option ?

Wrong date format usually means that the software you’ve opened it with has converted it automatically. Try to ensure the date is YYYY-MM-DD or for timestamps YYYY-MM-DD H:i:s as that is preferred to be imported.