Image field - not loading in list

Please, I need help…

why it is not showing image preview in the list. There should be preview.
What is the problem? I tried everything - several times reinstall suitecrm - making new modules - several times adding image fields and delete - all types jpg,png, tiff… everything… :woohoo: :woohoo: :woohoo: :woohoo:

Please I need help to solve this.

What I am doing wrong???

Hi. Don’t worry, you’re not doing anything wrong, you’re hitting a bug that is already reported but still waiting to be fixed:

That issue includes a way to work around this problem, so with a simple custom file change you can probably get your system working even while the bug is not fixed (supposing you’re only using images in one module - if you’re using more, the workaround won’t work).

Also, images are currently not showing in Edge browser (and, I hear, in IE11). You’ll just get a cross there like “X”.

1 Like

Thanx for your help… but nothing changed.
I have one module with images, replace code with module name “Image”, but I did not get preview in list…

I use Chrome browser. Tried with IE, Opera, Firefox…

The Module name I used was “contacts” because I had added an Image Field to the Contacts module. Normally, that’s what you would want to do, attach a field to an existing module (Contacts, Accounts, Products, etc.), not create a separate module just for images.

But I can teach you how I discovered what I needed so you can adapt it to your own case: just use your browser’s “Web developer” features to examine what is being rendered in the HTML of those subpanels. You can use “Inspect element”, or open web tools and easily find the relevant part by using a little magnifier that let’s you point at the element to see the HTML specific to that element.

Then compare your findings with what appears in another place where the image is showing correctly (like a detail view). This will make you see the difference and you can hard-code that in the custom file.

The picture in the detail view is broken like that

I use Version 7.11.18

Do you see any error is Console? Can you open the image via Direct URL?

The cosol don’t show any error. No the image can’t be shown via Direct URL saved in the ‘product image’ field.

It might be your permissions that is blocking the image from display. Do you see a 403 error ?

YES exactly ‘Access to this resource on the server is denied!’

can you change the permissions for the uploaded resources to 755 ?
The shell command to change it would be like

crmroot_directory > chmod -R 0755 upload/

look at the post. May be it’s help.