IIS PHP.INI not writeable?

Dear forum,

I am struggling with a access right issue on the php.ini file. I have read all posts on this and was able to solve most of the issues here, but not php.ini.

I Keep having the issue of ‘php.ini not writable’ during the installation on WIndows 8.1.
I was able to get rid of all other ‘not writable’ issues on the suitecrm directories, but not for php.ini.

I made sure the php.ini is writable. The general settings does not show ‘read-only’.

The security settings has ‘full control’ and ‘write’ settings assigned to all kinds of users like ‘IUSR’, ‘IIS_IUSRS’, ‘DefaultAppPool’, ‘NETWORK USER’ and ‘everybody’. I applied these settings not only to the php.ini file itself but also to all directories above php.ini.

I have checked that the user of the IIS process (w3wp.exe) is ‘DefaultAppPool’ which has full access rights to the php.ini file.

Does anybody has any clue how to get pass the php.ini writable check on IIS (in my case Windows 8.1) ?

Best Regards and Thanks,
Joost van der Schoot

open iis with administrator priviledges
edit your php.ini from iis…
it should work it does on my machine…

Thanks Bmwtourer,

The issue was something else.
I had to make the file ‘config_override.php’ writable to solve this.
The errormessage indicated php.ini however.