If this error persists, please have your administrator disable Ajax for this module

Dear All,

I am entering all my products details in the CRM and i close CRM but today morning i am getting error as mentioned in the subject line and snapshot attached here with when i checked my log i found below error.

Wed Jul 5 09:00:00 2017 [4527][58d0483b-49bc-b692-16a1-595c902b135f][FATAL] Query Failed:
SELECT * FROM calls_users
WHERE
= ‘683f8eda-4281-136b-a81e-595373b199f9’ AND
user_id = ‘58d0483b-49bc-b692-16a1-595c902b135f’ AND
deleted = 0
: MySQL error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '= ‘683f8eda-4281-136b-a81e-595373b199f9’ AND
user_id = ‘58d0483b-49bc-b692-1’ at line 3

Please Help me out how i can solve this issue

It looks like SuiteCRM is having trouble with a relationship between the calls module and the users module. Could you please disclose which version of SuiteCRM you are using?

Have you tried running a quick repair and rebuild? Could repair relationships? Does this resolve your issue?

We are using Version 7.4.3, Sugar Version 6.5.20 (Build 1001). we followed you you mentioned but sill we are facing same issue. 2nd we disable Ajax from the setting, now all module is working but relationship is not showing.

3rd issue we are facing same error “If this error persists, please have your administrator disable Ajax for this module” for role management and role management is not a module so we can not disable Ajax to resolved this issue.

Now for us the 3rd issue is more important because we can not define roles for users.

thanks

sher

Hi sherbahader, in my experience that AJAX message isn’t necessarily very precise, often the problem has nothing to do with AJAX.

The version you’re running has had about 17 releases after it, which means important security patches and hundreds of bug fixes - possibly the one you’re experiencing now.

Can you consider an upgrade? Make sure you have proper backups first. Or make a clone of your production system and try the upgrade on the clone.

As a last resort if you need to keep the system like this and workaround your problem, you could edit the user roles directly in the database, it shouldn’t be too difficult…

Hi,
Ajax is very hard to find issue.

1 ) version of php
2 ) version of php module
3 ) version of apache
4 ) if field is “required”… or not, then look in vardefs/studio
5 ) permission
6 ) …

for find a issue with Ajax, you must provide all informations, OS, Apache, Php, etc… All logs on all and All version

Regards

Hi!

I receive the same error message while trying to open the Opportunities menu.
Here is a screenshot:

Could you please help me what to do to solve this issue?

Thanks in advance!

Akos

Hi Akos,
I’m having the same problem like yours. Were you able to fix this issue? If so please help me to solve this.

Thanks,
Josua

I believe it’s a problem with your filters. Login into your SuiteCRM, customize the link below and open it on your browser:

yourdomain/index.php?action=index&module=Opportunities&searchFormTab=advanced_search&query=true&clear_query=true

If it doesn’t work you might need to reset your User Preferences from your profile.

Thanks,

AlxGr

2 Likes

Hi AlxGr,

Thanks for your reply.
The link you provided is working fine. But this error is coming in a different module.
I’m new to suiteCRM. Please help me.
Thanks

@Josua does that “other module” have a name? If you tell us, we can help you figure out how to replace the module name in that link with the actual module you’re referring to.