ical URL results in 500 Error / php 7.0 / crm v7.9.0

I’ve got a fully working install of SuiteCRM 7.9.0 with email and workflows working great.

I can’t get the iCal URL’s to work. When I copy the URL from the profile and paste into a browser, it results in a 500 error. This applies for all the URLs in the advanced tab.

I’ve made sure that cache custom modules themes data upload config_override.php folder/files are set at 775 and tried having all the cache and lower at 777.

Nothing in the error logs.

Anyone have any ideas?

Nothing in the error logs for a 500 error? That sounds a bit strange.

Are the error logs the suitecrm.log or PHP error logs because I would suspected you would get something from a 500 error in the PHP logs. Can you confirm which error logs you are referring to?

I turned on logging in the php.ini and the only thing that comes out is:

[30-May-2017 15:00:02 America/Chicago] PHP Fatal error:  Uncaught exception 'Exception' with message 'cron.php is CLI only.' in /home/***/public_html/suitecrm/include/utils.php:1692
Stack trace:
#0 /home/***/public_html/suitecrm/cron.php(49): sugar_die('cron.php is CLI...')
#1 {main}
  thrown in /home/***/public_html/suitecrm/include/utils.php on line 1692

I read about disabling the CLI check in the cron.php file, but that just means there are no errors logged.

What error in your php error logs do you get out when you access the URL via the browser? Just the above?

yep - that’s it - nothing in any of the other logs as well.

When I // the CLI warning in cron.php there are no errors in the error_log

Anyone have any ideas?


It was a permissions error (although I did run the terminal command) so the ical_server.php is now set at 644

Although now the calendar URL just asks for a login but never accepts it.

Both key and email address are correct

Exactly what are you using to launch the cron jobs?

If you go into Admin / Schedulers, are they running and reporting no errors there?

This is worth investigating although I doubt it’s related to your iCal error.

Then you could double-check the permissions on the “public” directory (I’m guessing that’s where the iCal file goes, is it?) - sticky bit, ownerships. The details, not just the “777” thing.

Hi - although I ran the command line permissions fix, the ical-server.php had incorrect permissions. I worked with my hosting provider now its’ working.

Although not right away, it took some hammering but now all is good

You seem to have some permissions degradation problems. if it’s not the cron jobs running as a different user than your web server, then it could be a good idea to check the default_permissions array in config.php

Normally people recommend using this

'default_permissions' =>
array (
'dir_mode' => 1517,
'file_mode' => 420,
'user' => 'youruser', // you must replace <youruser> with the actual value
'group' => 'yourgroup', // you must replace <yourgroup> with the actual value
1 Like

thanks for all the info !

The ical issue is now resolved.

Hello Comunity,

I have the same problem with the workflows for sending mail. And I get the same error. Could you solve this?

Thank you.

jrivas there were several issues described in this thread, and I don’t see how they relate to workflows or to sending mail…

It’s really better if you just started your own thread with your systems details, and the exact problem, and the exact error message. Thanks!

Hi pgr,

I’m trying to figure out reminders using the workflow module.
From the cpanel add the comand as indicated in the guide.
Cd / home / mydomine / public_html / myinstal; Php -f cron.php> / dev / null 2> & 1

But the programmed entries are not sent in the workflow and in the error log the following is output:
[10-Jul-2017 16:46:01 America / New_York] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘cron.php is CLI only.’ In /home/mydomine/public_html/myinstall/include/utils.php:1692
Stack trace:

0 /home/maydomine/public_html/myinstall/cron.php(49): sugar_die (‘cron.php is CLI …’)

1 {main}

Thrown in /home/mydomine/public_html/myinstall/include/utils.php on line 1692

Thanks for your help.

@jrivas the reason I’m asking you to start your own thread is because you have a different problem, and a different system. You just happen to be getting the same error message.

It gets really complicated for me to help out in multiple threads at once, when the subject lines are misleading:

Can I assume you have PHP 7.0 because you posted in a thread with PHP 7.0 in the subject line?

Can I assume you have SuiteCRM 7.9.0 because you posted in a thread with SuiteCRM 7.9.0 in the subject line?

You don’t seem to have an iCal problem at all, yet the subject line mentions it in first place…

Don’t worry, I’ll meet you in the other thread you create, and I will help you there. :slight_smile: just tell me your correct versions.