I want to love this program. Please help with this PHP.ini or Index.ini Formatting

Hello there, I have a pretty clean install compared to some of the issues I’ve seen here. Problem is, I am not very good at programming and really just wing it on a as-needed basis to install software for sales.

I have tried all the different php file resolutions but my syntax must be messed up. Can someone show me verbatim how to edit the file to hide php errors? I keep getting this non-fatal error:

**Notice** : Trying to access array offset on value of type bool in  **C:\xampp\htdocs\olc\data\Relationships\One2MRelationship.php**  on line  **108**

Everything else is working fine. I tried to remove the semicolon from the PHP.ini file on the error reporting lines where the default is listed. When I attempt to un-comment the section and restart the apache server, it corrupts the build and I cannot access the site.

Thank you so much for your help. A simple copy-paste of the correct settings would save my day!

Hi, welcome to the Community! :tada:

Set display_errors to Off in your php.ini and restart your web server.

To find your correct php.ini, if in doubt, see Admin / Diagnostics / phpinfo

Could you show me verbatim

how it's supposed to appear?

It may have been the incorrect file as well :stuck_out_tongue:

EDIT: In my admin panel I only have “diagnostic tools”

I am also running on XAMPP

Thanks for the welcome!

I am also getting this error:

Notice: Trying to access array offset on value of type null in C:\xampp\htdocs\olc\include\SearchForm\SearchForm2.php on line 531

Is there anything I can install to get rid of these or is disabling them ok? (still havent managed to disable properly)

That’s it, go into Admin / Diagnostic Tool / Output from phpinfo()

Select only that checkbox, hit Execute diagnostic button, download the zip, unzip it, open the HTML file inside and inspect it in your browser.

One of the first items listed should Loaded Configuration File which has the path to your php.ini file.

Now go open that file in Notepad (or similar) and find a line that says

display_errors = On

and change it to

display_errors = Off

If the line starts with a semicolon (;) remove that character, it makes the line a comment.

Save, Exit, restart XAMPP, test again.