It should be the simplest thing to setup an email. I can’t stand this “Data Error” in Email Settings anymore. It came out of nowhere.

PLEASE, how can I fix this?

OR how can I reset the email info all over again? I have uninstalled the entire thing before to fix the error. It still shows up!


I guess that no one answered because, essentially you have not asked anything!

Please be more specific:
. SuiteCRM version, OS version, PHP version
. is this a clean install or an upgrade. If it’s an upgrade, of which version? Was it working before?
. have you modified anything (eg php version, webserver, os, custom code, etc.)?
. where does this occur?
. precise steps to reproduce the error
. screenshot of the error
. any customisation that you have
. error logs at the time in which the error occurs (there are at least three logs to check: suitecrm, php/apache or webserver, browser console)

Please understand that, without the minimum information it’s almost impossible to help!

I’m sorry about that, it’s just that I have been trying to fix it for the past 3 days. I had to uninstall the whole thing and reinstall it setting it up all over again. I just got frustrated

Here are all the details

Latest SuiteCRM Version - clean install
Hosting OS Proprietary *nix
PHP Version 7.3.4
Did not modify the code

It occurs in Admin > Email Settings > Settings > Mail Accounts

I have no problem setting up any emails and testing them, they work.

It all started when I setup inbound email and when I noticed that I can send emails from the system email but not profile email, eventhough they are the same email. The profile email uses my full name and applies the signature when sent.

So then I removed all emails and want to set them up all over again but I cant because I see ‘Data Error’ under the Profile email settings.


Under email settings when I tick ‘User may send as this account’s Identity’ the email is sent.

But when I tick ‘users may send as themselves’ I can the following error:

Error Sending Email. Please contact your administrator for assistance.

And the error log shows the following:

Thu Apr 25 08:07:49 2019 [8518][1][FATAL] SugarPHPMailer encountered an error: Invalid address: (Reply-To): My Name <myemail@email.com
Thu Apr 25 08:07:49 2019 [8518][1][FATAL] SugarPHPMailer encountered an error: Invalid address: (From): My Name <myemail@email.com
Thu Apr 25 08:07:49 2019 [8518][1][FATAL] SugarPHPMailer encountered an error: Invalid address: (From): My Name <myemail@email.com
Thu Apr 25 08:07:49 2019 [8518][1][FATAL] SugarPHPMailer encountered an error: Invalid address: (From): My Name <myemail@email.com

Please be specific. There are many new versions coming out.

Which settings: how do you get to these settings? (there are many email settings in SuiteCRM)

Does the error message say this or have you modified it to hide both your name and email address here in the Forum?

I am not sure if this version is supported. You should check the compatibility matrix for your version to be 100% sure that it is supported.

Please have a look here to understand if it is the same issue or similar. In case add your comments there.

version SuiteCRM 7.11.3

Under email setting: Admin > Email Settings

Changed the name and email to hide it from forum

I checked the matrix and switched to php 7.2

I dont know where ‘here’ points to?

Sorry, for some reason I didn’t paste the link!

Here it is:

I have finally gotten it to work after 3 loooong days! Just so that I can help other people since ‘some ppl’ over here dont even care to reply.

I deleted everything and have done a manual install. I didn’t even use an installer from cpanel. Everything was done manual and I STILL GOT THE ERROR!!!. But now I knew this was not from the server nor the crm system. It’s actually FREAKING CHROME!!! I used firefox, and the error is gone, when I sign on chrome the error is there still! I configured the settings on firefox and will never ever touch chrome again for a long period of time.

Hope this helps somebody.